summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb
new file mode 100644
index 00000000..aec820cb
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11279.bb
@@ -0,0 +1,73 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & Apache-2.0"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://LICENSE.md;md5=488d74376edf2765f6e78d271543dde3 \
9 file://NOTICES.txt;md5=7f4fbc3eb2c34807465e63b1ec3c9d1a"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=master \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;branch=master \
13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=SPIRV-Tools;name=spirv-tools;branch=sdk-1.3.204 \
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0003-Improve-Reproducibility-for-src-package.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 file://991fd3d661efcb4fb6df63b76310d6e634b05c39.patch \
18 "
19
20SRC_URI:append:class-native = " file://0001-fix-tblgen.patch"
21
22SRCREV_igc = "b2c14d219dc4d3e384f217ef6bd2c2db1bd6b9ce"
23SRCREV_vc = "4ce354da51f219bbdfa9c4cd5d8f640e92e38511"
24SRCREV_spirv-tools = "45dd184c790d6bfc78a5a74a10c37e888b1823fa"
25SRCREV_spirv-headers = "b42ba6d92faf6b4938e6f22ddd186dbdacc98d78"
26
27SRCREV_FORMAT = "igc_vc_spirv-tools_spirv-headers"
28
29# Used to replace with relative path in reproducibility patch
30export B
31
32S = "${WORKDIR}/git"
33
34inherit cmake pkgconfig
35
36CXXFLAGS:append = " -Wno-error=nonnull"
37
38COMPATIBLE_HOST = '(x86_64).*-linux'
39COMPATIBLE_HOST:libc-musl = "null"
40
41DEPENDS += " flex-native bison-native clang opencl-clang"
42DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
43
44RDEPENDS:${PN} += "opencl-clang"
45
46PACKAGECONFIG ??= "vc"
47PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
48
49EXTRA_OECMAKE = " \
50 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
51 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
52 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
53 -DIGC_OPTION__LLVM_MODE=Prebuilds \
54 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
55 -DLLVM_LINK_EXE=${STAGING_BINDIR_NATIVE}/llvm-link \
56 "
57
58do_install:append:class-native () {
59 install -d ${D}${bindir}
60 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
61 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
62 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
63 install ${B}/IGC/Release/vcb ${D}${bindir}/
64 fi
65}
66
67BBCLASSEXTEND = "native nativesdk"
68
69UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
70
71FILES:${PN} += " \
72 ${libdir}/igc/NOTICES.txt \
73 "