summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
new file mode 100644
index 00000000..c3d9f10b
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
@@ -0,0 +1,68 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=23;md5=4a985f2545dd5a846e205b1e60a51cd9 \
9 file://NOTICES.txt;md5=7f4fbc3eb2c34807465e63b1ec3c9d1a"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=master \
12 git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;branch=master \
13 git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=SPIRV-Tools;name=spirv-tools;branch=master \
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0001-llvm_deps.cmake-don-t-copy-header-file-when-building.patch \
16 file://0003-Improve-Reproducibility-for-src-package.patch \
17 file://0004-find-external-llvm-tblgen.patch \
18 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
19 file://0001-llvm-link-external.patch \
20 "
21
22SRCREV_igc = "775a850f9b0c2d7249503b47ad6bd39a4eb9b3d7"
23SRCREV_vc = "5066d947985dd0c5107765daec5f24f735f3259a"
24SRCREV_spirv-tools = "eeb973f5020a5f0e92ad6da879bc4df9f5985a1c"
25SRCREV_spirv-headers = "ae217c17809fadb232ec94b29304b4afcd417bb4"
26
27# Used to replace with relative path in reproducibility patch
28export B
29
30S = "${WORKDIR}/git"
31
32inherit cmake pkgconfig
33
34CXXFLAGS:append = " -Wno-error=nonnull"
35
36COMPATIBLE_HOST = '(x86_64).*-linux'
37COMPATIBLE_HOST:libc-musl = "null"
38
39DEPENDS += " flex-native bison-native clang opencl-clang"
40DEPENDS:append:class-target = " clang-cross-x86_64 intel-graphics-compiler-native"
41
42RDEPENDS:${PN} += "opencl-clang"
43
44PACKAGECONFIG ??= "vc"
45PACKAGECONFIG[vc] = "-DIGC_BUILD__VC_ENABLED=ON -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR=ON -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC=ON -DIGC_OPTION__SPIRV_TRANSLATOR_MODE=Prebuilds,-DIGC_BUILD__VC_ENABLED=OFF,"
46
47EXTRA_OECMAKE = " \
48 -DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} \
49 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
50 -DVC_INTRINSICS_SRC="${S}/vc-intrinsics" \
51 -DIGC_OPTION__LLVM_MODE=Prebuilds \
52 "
53
54do_install:append:class-native () {
55 install -d ${D}${bindir}
56 install ${B}/IGC/Release/elf_packager ${D}${bindir}/
57 if ${@bb.utils.contains('PACKAGECONFIG', 'vc', 'true', 'false', d)}; then
58 install ${B}/IGC/Release/CMCLTranslatorTool ${D}${bindir}/
59 fi
60}
61
62BBCLASSEXTEND = "native nativesdk"
63
64UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
65
66FILES:${PN} += " \
67 ${libdir}/igc/NOTICES.txt \
68 "