summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch
deleted file mode 100644
index db834c99..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0002-IGC-VectorCompiler-CMakeLists.txt-link-to-external-L.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 92a663dd55917fdfad5ae4daa173a9d18df0ee9e Mon Sep 17 00:00:00 2001
2From: Dongwon Kim <dongwon.kim@intel.com>
3Date: Wed, 18 Aug 2021 19:14:28 -0700
4Subject: [PATCH 2/5] IGC/VectorCompiler/CMakeLists.txt: link to external
5 LLVMGenXIntrinsics
6
7By default LLVMGenXIntrinsics is to be build In-tree, but we want to
8link externally.
9
10Upstream-Status: Inappropriate [configuration specific]
11
12Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
13Signed-off-by: Dongwon Kim <dongwon.kim@intel.com>
14---
15 IGC/VectorCompiler/CMakeLists.txt | 16 ----------------
16 1 file changed, 16 deletions(-)
17
18diff --git a/IGC/VectorCompiler/CMakeLists.txt b/IGC/VectorCompiler/CMakeLists.txt
19index 0b26072f0..bf1cd939d 100644
20--- a/IGC/VectorCompiler/CMakeLists.txt
21+++ b/IGC/VectorCompiler/CMakeLists.txt
22@@ -43,22 +43,6 @@ if(LLVM_ON_WIN32)
23 endif()
24
25 # --- VC Intrinsics ---
26-
27-if(DEFINED VC_INTRINSICS_SRC)
28- set(INTRSRC "${VC_INTRINSICS_SRC}/GenXIntrinsics")
29-endif()
30-
31-if(NOT DEFINED INTRSRC)
32- set(INTRSRC "${CMAKE_CURRENT_SOURCE_DIR}/../../../vc-intrinsics/GenXIntrinsics")
33-endif()
34-
35-message(STATUS "[VC] Using vc-intrinsics source from: ${INTRSRC}")
36-# Trick intrinsics.
37-set(BUILD_EXTERNAL YES)
38-# We are using prebuilt SPIRV and building intrinsics.
39-set(INTRBUILD "${CMAKE_CURRENT_BINARY_DIR}/intrbuild")
40-add_subdirectory(${INTRSRC} ${INTRBUILD} EXCLUDE_FROM_ALL)
41-
42 include(cmake/spirv.cmake)
43
44 set(IGC_OPTION__VC_DISABLE_BIF_DEFAULT OFF)
45--
462.20.1
47