summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb
new file mode 100644
index 00000000..fe5f886c
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb
@@ -0,0 +1,64 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.17 \
12 file://disable-werror.patch \
13 file://add-missing-cstdint-header-to-fix-compile-with-gcc13.patch \
14 "
15
16SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \
17 file://external-ocloc.patch \
18 "
19
20SRCREV = "0bb5b3408e6cb61b477e7cad296fd278b11e73be"
21
22S = "${WORKDIR}/git"
23
24DEPENDS += " intel-graphics-compiler gmmlib"
25DEPENDS:append:class-target = " intel-compute-runtime-native libva"
26
27RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
28
29inherit cmake pkgconfig
30
31COMPATIBLE_HOST = '(x86_64).*-linux'
32COMPATIBLE_HOST:libc-musl = "null"
33
34EXTRA_OECMAKE = " \
35 -DIGC_DIR=${STAGING_INCDIR}/igc \
36 -DBUILD_TYPE=Release \
37 -DSKIP_UNIT_TESTS=1 \
38 -DCCACHE_ALLOWED=FALSE \
39 -DNEO_DISABLE_LD_LLD=ON \
40 -DNEO_DISABLE_LD_GOLD=ON \
41 "
42
43EXTRA_OECMAKE:append:class-target = " \
44 -Docloc_cmd_prefix=ocloc \
45 "
46
47PACKAGECONFIG ??= ""
48PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
49
50do_install:append:class-native() {
51 install -d ${D}${bindir}
52 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
53}
54
55FILES:${PN} += " \
56 ${libdir}/intel-opencl/libigdrcl.so \
57 ${libdir}/libocloc.so \
58 "
59
60FILES:${PN}-dev = "${includedir}"
61
62BBCLASSEXTEND = "native nativesdk"
63
64UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"