summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb
new file mode 100644
index 00000000..faf00757
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.08.22549.bb
@@ -0,0 +1,63 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9280143b568466d8fbe385f838078b93 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \
12 "
13
14SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \
15 file://external-ocloc.patch \
16 "
17
18SRCREV = "315769424d4b59a29b11ebb4d6418a0ac0a0eeac"
19
20S = "${WORKDIR}/git"
21
22DEPENDS += " intel-graphics-compiler gmmlib"
23DEPENDS:append:class-target = " intel-compute-runtime-native libva"
24
25RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
26
27inherit cmake pkgconfig
28
29COMPATIBLE_HOST = '(x86_64).*-linux'
30COMPATIBLE_HOST:libc-musl = "null"
31
32EXTRA_OECMAKE = " \
33 -DIGC_DIR=${STAGING_INCDIR}/igc \
34 -DBUILD_TYPE=Release \
35 -DSKIP_UNIT_TESTS=1 \
36 -DCCACHE_ALLOWED=FALSE \
37 -DNEO_DISABLE_LD_LLD=ON \
38 -DNEO_DISABLE_LD_GOLD=ON \
39 "
40EXTRA_OECMAKE:append:class-native = " -DNEO_DISABLE_BUILTINS_COMPILATION=ON"
41
42EXTRA_OECMAKE:append:class-target = " \
43 -Docloc_cmd_prefix=ocloc \
44 "
45
46PACKAGECONFIG ??= ""
47PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
48
49do_install:append:class-native() {
50 install -d ${D}${bindir}
51 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
52}
53
54FILES:${PN} += " \
55 ${libdir}/intel-opencl/libigdrcl.so \
56 ${libdir}/libocloc.so \
57 "
58
59FILES:${PN}-dev = "${includedir}"
60
61BBCLASSEXTEND = "native nativesdk"
62
63UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"