summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb
new file mode 100644
index 00000000..2a34526a
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.40.21182.bb
@@ -0,0 +1,61 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=983b0c493ea3dc3c21a90ff743bf90e4 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 "
13
14SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch"
15
16SRCREV = "3269e719a3ee7bcd97c50ec2cfe78fc8674adec0"
17
18S = "${WORKDIR}/git"
19
20DEPENDS += " intel-graphics-compiler gmmlib"
21DEPENDS:append:class-target = " intel-compute-runtime-native libva"
22
23RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
24
25inherit cmake pkgconfig
26
27COMPATIBLE_HOST = '(x86_64).*-linux'
28COMPATIBLE_HOST:libc-musl = "null"
29
30EXTRA_OECMAKE = " \
31 -DIGC_DIR=${STAGING_INCDIR}/igc \
32 -DBUILD_TYPE=Release \
33 -DSKIP_UNIT_TESTS=1 \
34 -DCCACHE_ALLOWED=FALSE \
35 -DNEO_DISABLE_LD_LLD=ON \
36 -DNEO_DISABLE_LD_GOLD=ON \
37 "
38EXTRA_OECMAKE:append:class-native = " -DNEO_DISABLE_BUILTINS_COMPILATION=ON"
39
40EXTRA_OECMAKE:append:class-target = " \
41 -Dcloc_cmd_prefix=ocloc \
42 "
43
44PACKAGECONFIG ??= ""
45PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
46
47do_install:append:class-native() {
48 install -d ${D}${bindir}
49 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
50}
51
52FILES:${PN} += " \
53 ${libdir}/intel-opencl/libigdrcl.so \
54 ${libdir}/libocloc.so \
55 "
56
57FILES:${PN}-dev = "${includedir}"
58
59BBCLASSEXTEND = "native nativesdk"
60
61UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"