summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb
new file mode 100644
index 00000000..c97e09f8
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.33.20678.bb
@@ -0,0 +1,58 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=983b0c493ea3dc3c21a90ff743bf90e4 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 file://0001-Revert-Change-builtin-kernels-compilation-process.patch \
13 "
14
15SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch"
16
17SRCREV = "0a106c150e3cde872b4728d766134d99c02e8b1c"
18
19S = "${WORKDIR}/git"
20
21DEPENDS += " intel-graphics-compiler gmmlib"
22DEPENDS:append:class-target = " intel-compute-runtime-native libva"
23
24RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
25
26inherit cmake pkgconfig
27
28COMPATIBLE_HOST = '(x86_64).*-linux'
29COMPATIBLE_HOST:libc-musl = "null"
30
31EXTRA_OECMAKE = " \
32 -DIGC_DIR=${STAGING_INCDIR}/igc \
33 -DBUILD_TYPE=Release \
34 -DSKIP_UNIT_TESTS=1 \
35 -DCCACHE_ALLOWED=FALSE \
36 "
37EXTRA_OECMAKE:append:class-target = " \
38 -Dcloc_cmd_prefix=ocloc \
39 "
40
41PACKAGECONFIG ??= ""
42PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
43
44do_install:append:class-native() {
45 install -d ${D}${bindir}
46 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
47}
48
49FILES:${PN} += " \
50 ${libdir}/intel-opencl/libigdrcl.so \
51 ${libdir}/libocloc.so \
52 "
53
54FILES:${PN}-dev = "${includedir}"
55
56BBCLASSEXTEND = "native nativesdk"
57
58UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"