summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
new file mode 100644
index 00000000..5525b66a
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
@@ -0,0 +1,43 @@
1SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \
3is an open source project to converge Intel's development efforts \
4on OpenCL(TM) compute stacks supporting the GEN graphics hardware \
5architecture."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 "
13
14SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1"
15
16S = "${WORKDIR}/git"
17
18DEPENDS += " intel-graphics-compiler gmmlib clang"
19DEPENDS_append_class-target = " intel-compute-runtime-native"
20
21RDEPENDS_${PN} += " intel-graphics-compiler gmmlib"
22
23inherit cmake pkgconfig
24
25COMPATIBLE_HOST = '(x86_64).*-linux'
26COMPATIBLE_HOST_libc-musl = "null"
27
28EXTRA_OECMAKE = " \
29 -DIGC_DIR=${STAGING_INCDIR}/igc \
30 -DBUILD_TYPE=Release \
31 -DSKIP_UNIT_TESTS=1 \
32 -DCCACHE_ALLOWED=FALSE \
33 -Dcloc_cmd_prefix=ocloc \
34 "
35
36FILES_${PN} += " \
37 ${libdir}/intel-opencl/libigdrcl.so \
38 ${libdir}/intel-opencl/libocloc.so \
39 "
40
41BBCLASSEXTEND = "native nativesdk"
42
43UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"