summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend')
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend22
1 files changed, 1 insertions, 21 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
index 3f304215..96011f1d 100644
--- a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
@@ -1,9 +1,6 @@
1FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/files:" 1FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/files:"
2 2
3SPIRV10_SRCREV = "fe4d6b767363a1995ccbfca27f79efb10dcfe110" 3SPIRV_SRCREV = "fe4d6b767363a1995ccbfca27f79efb10dcfe110"
4SPIRV11_SRCREV = "ca3a50e6e3193e399d26446d4f74a90e2a531f3a"
5
6SPIRV_SRCREV = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '${SPIRV10_SRCREV}', '${SPIRV11_SRCREV}', d)}"
7 4
8SRC_URI_LLVM10_PATCHES = " \ 5SRC_URI_LLVM10_PATCHES = " \
9 file://llvm10-0001-llvm-spirv-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \ 6 file://llvm10-0001-llvm-spirv-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
@@ -28,18 +25,6 @@ SRC_URI_LLVM10_PATCHES = " \
28 file://llvm10-0015-ispc-10_0_vXi1calling_avx512_i8_i16.patch \ 25 file://llvm10-0015-ispc-10_0_vXi1calling_avx512_i8_i16.patch \
29 " 26 "
30 27
31SRC_URI_LLVM11_PATCHES = " \
32 file://llvm11-0001-llvm-spirv-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
33 file://llvm11-0002-Add-support-for-cl_ext_float_atomics-in-SPIRVWriter.patch;patchdir=llvm/projects/llvm-spirv \
34 file://llvm11-0001-OpenCL-3.0-support.patch \
35 file://llvm11-0002-Memory-leak-fix-for-Managed-Static-Mutex.patch \
36 file://llvm11-0003-Remove-repo-name-in-LLVM-IR.patch \
37 file://llvm11-0004-Remove-__IMAGE_SUPPORT__-macro-for-SPIR-since-SPIR-d.patch \
38 file://llvm11-0005-Avoid-calling-ParseCommandLineOptions-in-BackendUtil.patch \
39 file://llvm11-0006-OpenCL-support-cl_ext_float_atomics.patch \
40 file://llvm11-0007-ispc-11_0_11_1_disable-A-B-A-B-in-InstCombine.patch \
41 file://llvm11-0008-ispc-11_0_11_1_packed_load_store_avx512.patch \
42 "
43SRC_URI_LLVM12_PATCHES = " \ 28SRC_URI_LLVM12_PATCHES = " \
44 file://llvm12-0001-Remove-__IMAGE_SUPPORT__-macro-for-SPIR-since-SPIR-d.patch \ 29 file://llvm12-0001-Remove-__IMAGE_SUPPORT__-macro-for-SPIR-since-SPIR-d.patch \
45 file://llvm12-0002-Avoid-calling-ParseCommandLineOptions-in-BackendUtil.patch \ 30 file://llvm12-0002-Avoid-calling-ParseCommandLineOptions-in-BackendUtil.patch \
@@ -51,12 +36,7 @@ SRC_URI_LLVM12_PATCHES = " \
51 36
52SPIRV_LLVM10_SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=llvm_release_100;destsuffix=git/llvm/projects/llvm-spirv;name=spirv" 37SPIRV_LLVM10_SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=llvm_release_100;destsuffix=git/llvm/projects/llvm-spirv;name=spirv"
53 38
54SPIRV_LLVM11_SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=llvm_release_110;destsuffix=git/llvm/projects/llvm-spirv;name=spirv"
55
56
57
58SRC_URI:append:intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '10.0.1', ' ${SPIRV_LLVM10_SRC_URI} ${SRC_URI_LLVM10_PATCHES} ', '', d)}" 39SRC_URI:append:intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '10.0.1', ' ${SPIRV_LLVM10_SRC_URI} ${SRC_URI_LLVM10_PATCHES} ', '', d)}"
59SRC_URI:append:intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '11.1.0', ' ${SPIRV_LLVM11_SRC_URI} ${SRC_URI_LLVM11_PATCHES} ', '', d)}"
60SRC_URI:append:intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '12.0.0', ' ${SRC_URI_LLVM12_PATCHES} ', '', d)}" 40SRC_URI:append:intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '12.0.0', ' ${SRC_URI_LLVM12_PATCHES} ', '', d)}"
61 41
62SRCREV_spirv = "${@bb.utils.contains_any('LLVMVERSION', [ '13.0.0', '12.0.0' ], '', '${SPIRV_SRCREV}', d)}" 42SRCREV_spirv = "${@bb.utils.contains_any('LLVMVERSION', [ '13.0.0', '12.0.0' ], '', '${SPIRV_SRCREV}', d)}"