summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch
new file mode 100644
index 00000000..c58e7d98
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-skip-building-tests.patch
@@ -0,0 +1,50 @@
1From 91db4c3cf7f290a3cab5caa316fc25a60dd409f1 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Fri, 16 Aug 2019 20:25:16 +0800
4Subject: [PATCH] llvm-spirv: skip including tests
5
6Some of these need clang to be built and since we're building this in-tree,
7that leads to problems when compiling libcxx, compiler-rt which aren't built
8in-tree.
9
10Instead of using SPIRV_SKIP_CLANG_BUILD to skip clang build and adding this to
11all components, disable the building of tests altogether.
12
13Upstream-Status: Inappropriate
14
15Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
16---
17 CMakeLists.txt | 10 ----------
18 1 file changed, 10 deletions(-)
19
20diff --git a/CMakeLists.txt b/CMakeLists.txt
21index d632a50..81ddf62 100644
22--- a/CMakeLists.txt
23+++ b/CMakeLists.txt
24@@ -15,13 +15,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
25 set(CMAKE_CXX_STANDARD 11)
26 set(CMAKE_CXX_STANDARD_REQUIRED ON)
27
28- if(LLVM_INCLUDE_TESTS)
29- set(LLVM_TEST_COMPONENTS
30- llvm-as
31- llvm-dis
32- )
33- endif(LLVM_INCLUDE_TESTS)
34-
35 find_package(LLVM 8.0.0 REQUIRED
36 COMPONENTS
37 Analysis
38@@ -56,9 +49,6 @@ set(LLVM_SPIRV_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
39
40 add_subdirectory(lib/SPIRV)
41 add_subdirectory(tools/llvm-spirv)
42-if(LLVM_INCLUDE_TESTS)
43- add_subdirectory(test)
44-endif(LLVM_INCLUDE_TESTS)
45
46 install(
47 FILES
48--
492.7.4
50