summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
deleted file mode 100644
index ab48f5fb..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1SUMMARY = "Intel(R) Implicit SPMD Program Compiler"
2DESCRIPTION = "ispc is a compiler for a variant of the C programming language, \
3with extensions for single program, multiple data programming."
4HOMEPAGE = "https://github.com/ispc/ispc"
5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a"
9
10inherit cmake python3native ptest
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Fix-QA-Issues.patch \
18 file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \
19 file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \
20 file://ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch \
21 file://run-ptest \
22 "
23
24SRCREV = "ee43967286215a0511c2bc090e604848b4a32bed"
25
26COMPATIBLE_HOST = '(x86_64).*-linux'
27
28DEPENDS += " clang-native bison-native flex-native"
29DEPENDS:append:class-target = " clang"
30RDEPENDS:${PN}-ptest += " python3-multiprocessing"
31
32YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
33
34do_configure:prepend() {
35 sed -i -e 's#\${BISON_EXECUTABLE}.*#\${BISON_EXECUTABLE} ${YFLAGS} #g' ${S}/CMakeLists.txt
36 sed -i -e 's#\${FLEX_EXECUTABLE}.*#\${FLEX_EXECUTABLE} \-L #g' ${S}/CMakeLists.txt
37}
38
39do_install_ptest() {
40 cp -rf ${S}/run_tests.py ${D}${PTEST_PATH}
41 cp -rf ${S}/common.py ${D}${PTEST_PATH}
42 cp -rf ${S}/tests ${D}${PTEST_PATH}
43 cp -rf ${S}/test_static.isph ${D}${PTEST_PATH}
44 cp -rf ${S}/fail_db.txt ${D}${PTEST_PATH}
45 cp -rf ${S}/test_static.cpp ${D}${PTEST_PATH}
46}
47
48EXTRA_OECMAKE += " \
49 -DISPC_INCLUDE_TESTS=OFF \
50 -DISPC_INCLUDE_EXAMPLES=OFF \
51 -DISPC_NO_DUMPS=ON \
52 -DARM_ENABLED=OFF \
53 -DISPC_CROSS=ON \
54 -DISPC_ANDROID_TARGET=OFF \
55 -DISPC_FREEBSD_TARGET=OFF \
56 -DISPC_WINDOWS_TARGET=OFF \
57 -DISPC_IOS_TARGET=OFF \
58 -DISPC_PS4_TARGET=OFF \
59 -DSYSROOT_DIR=${STAGING_DIR} \
60 -DCLANG_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang \
61 -DCLANGPP_EXECUTABLE=${STAGING_BINDIR_NATIVE}/clang++ \
62 -DLLVM_DIS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-dis \
63 -DLLVM_AS_EXECUTABLE=${STAGING_BINDIR_NATIVE}/llvm-as \
64 "
65BBCLASSEXTEND = "native nativesdk"