summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend11
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.8.bbappend41
2 files changed, 52 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend
new file mode 100644
index 00000000..7e943964
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend
@@ -0,0 +1,11 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_i586-nlp-32-intel-common = "4.8.0-rc4"
4SRCREV_meta_i586-nlp-32-intel-common = "8cb7317502c2577f8c83eaf1c061603023824313"
5SRCREV_machine_i586-nlp-32-intel-common = "3eab887a55424fc2c27553b7bfe32330df83f7b8"
6
7COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
8KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
9KMACHINE_i586-nlp-32-intel-common = "intel-quark"
10
11KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.8.bbappend b/common/recipes-kernel/linux/linux-yocto_4.8.bbappend
new file mode 100644
index 00000000..412accf9
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_4.8.bbappend
@@ -0,0 +1,41 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.8.0-rc4"
4SRCREV_META_INTEL_COMMON = "8cb7317502c2577f8c83eaf1c061603023824313"
5SRCREV_MACHINE_INTEL_COMMON = "a7d71794e4e38d2f861c1b1dbff761ae0b0836b3"
6
7KBRANCH_INTEL_COMMON = "standard/base"
8
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32"
12KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
13SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
14SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
15KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
16
17LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
18COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
19KMACHINE_corei7-64-intel-common = "intel-corei7-64"
20KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
21SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
22SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25# Quark / X1000 BSP Info
26LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
27COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
28KMACHINE_i586-nlp-32-intel-common = "intel-quark"
29KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
30SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
31SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
32KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
33
34
35# For Crystalforest and Romley
36KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
37KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
38
39# For FRI2, NUC
40KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
41KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"