summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/recipes-corpus/calgary-corpus/calgary-corpus.bb24
-rw-r--r--common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb31
2 files changed, 0 insertions, 55 deletions
diff --git a/common/recipes-corpus/calgary-corpus/calgary-corpus.bb b/common/recipes-corpus/calgary-corpus/calgary-corpus.bb
deleted file mode 100644
index 17b8fdf8..00000000
--- a/common/recipes-corpus/calgary-corpus/calgary-corpus.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Set of files for testing losless compression algorithms"
2DESCRIPTION = "Set of files for testing losless compression algorithms"
3HOMEPAGE = "http://corpus.canterbury.ac.nz"
4SECTION = "misc"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
7
8# The tarball doesn't extract a directory, so ask bitbake to make one
9SRC_URI = "http://corpus.canterbury.ac.nz/resources/calgary.tar.gz;subdir=${BP}"
10SRC_URI[md5sum] = "651d06b35d3d39522157cf8dc4a3d01c"
11SRC_URI[sha256sum] = "e109eebdc19c5cee533c58bd6a49a4be3a77cc52f84ba234a089148a4f2093b7"
12
13inherit allarch
14
15do_install () {
16 # do_unpack creates this directory but we don't want to install it, so
17 # delete it now.
18 rm -rf ${S}/patches
19
20 install -d ${D}/lib/firmware
21 install -m 664 ${S}/* ${D}/lib/firmware
22}
23
24FILES_${PN} = "/lib/firmware/*"
diff --git a/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb b/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb
deleted file mode 100644
index db64e534..00000000
--- a/common/recipes-corpus/canterbury-corpus/canterbury-corpus.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Intel Quick Assist Driver - Canterbury Corpus"
2DESCRIPTION = "Set of files for testing losless compression algorithms \
3 for Intel Crystal Forest BSP Quick Assist Technology Software Package"
4
5HOMEPAGE = "http://corpus.canterbury.ac.nz"
6SECTION = "misc"
7LICENSE = "GPLv2"
8
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
10
11inherit allarch
12
13# The tarball doesn't extract a directory, so ask bitbake to make one
14SRC_URI = "http://corpus.canterbury.ac.nz/resources/cantrbry.tar.gz;subdir=${BP}"
15SRC_URI[md5sum] = "442e56cfffdf460d25b0b91650a55908"
16SRC_URI[sha256sum] = "f140e8a5b73d3f53198555a63bfb827889394a42f20825df33c810c3d5e3f8fb"
17
18FILES_${PN} = "/lib/firmware/*"
19
20do_install () {
21 # do_unpack creates this directory but we don't want to install it, so
22 # delete it now.
23 rm -rf ${S}/patches
24
25 install -d ${D}${base_libdir}/firmware
26 install -m 644 ${S}/* ${D}${base_libdir}/firmware
27}
28
29# The corpus contains Sparc binaries with unexpected symbol hash tables, so
30# silence the QA tests that will otherwise emit errors.
31INSANE_SKIP_${PN} = "arch ldflags"