summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libva/libva_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/libva/libva_1.6.2.bb')
-rw-r--r--common/recipes-multimedia/libva/libva_1.6.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libva/libva_1.6.2.bb b/common/recipes-multimedia/libva/libva_1.6.2.bb
new file mode 100644
index 00000000..b8528a70
--- /dev/null
+++ b/common/recipes-multimedia/libva/libva_1.6.2.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
14BUGTRACKER = "https://bugs.freedesktop.org"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/libva/${BP}.tar.bz2"
21
22SRC_URI[md5sum] = "430cc2742df60204f121409c06039d09"
23SRC_URI[sha256sum] = "c417f09cdeef549e54f4be5f9876026513afeac395c5be28750b431d848c8bd0"
24
25DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
26
27inherit autotools pkgconfig
28
29EXTRA_OECONF = "--disable-dummy-driver"
30
31PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
32 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
33PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
34PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
35
36PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
37
38RDEPENDS_${PN}-tpi =+ "${PN}"
39RDEPENDS_${PN}-x11 =+ "${PN}"
40RDEPENDS_${PN}-glx =+ "${PN}-x11"
41RDEPENDS_${PN}-egl =+ "${PN}-x11"
42
43FILES_${PN}-dbg += "${libdir}/dri/.debug"
44
45FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
46FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
49FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"