diff options
Diffstat (limited to 'common/recipes-multimedia/gstreamer')
5 files changed, 101 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb new file mode 100644 index 00000000..784e0c55 --- /dev/null +++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require gstreamer-vaapi.inc | ||
2 | |||
3 | DEPENDS += "gstreamer gst-plugins-base gst-plugins-bad" | ||
4 | |||
5 | SRC_URI += "file://wayland-compile.patch" | ||
6 | |||
7 | GST_API_VERSION = "0.10" | ||
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb new file mode 100644 index 00000000..b8ad2a57 --- /dev/null +++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | require gstreamer-vaapi.inc | ||
2 | |||
3 | DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
4 | |||
5 | GST_API_VERSION = "1.0" | ||
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc b/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc new file mode 100644 index 00000000..9fc32481 --- /dev/null +++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "VA-API support to GStreamer" | ||
2 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ | ||
3 | based plugins for GStreamer and helper libraries: `vaapidecode', \ | ||
4 | `vaapiconvert', and `vaapisink'." | ||
5 | |||
6 | REALPN = "gstreamer-vaapi" | ||
7 | FILESPATH = "${@base_set_filespath(["${FILE_DIRNAME}/${REALPN}", "${FILE_DIRNAME}/${REALPN}"], d)}" | ||
8 | |||
9 | LICENSE = "LGPLv2.1+" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" | ||
11 | |||
12 | DEPENDS = "libva" | ||
13 | |||
14 | SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/${REALPN}/${REALPN}-${PV}.tar.bz2 \ | ||
15 | file://install-tests.patch" | ||
16 | |||
17 | SRC_URI[md5sum] = "7b1ede7193bc5a0aca921c490684f7b5" | ||
18 | SRC_URI[sha256sum] = "68e0598456fe17085f6b8b1ce3da066322cc02c363955fb319776a5404d2b0da" | ||
19 | |||
20 | S = "${WORKDIR}/${REALPN}-${PV}" | ||
21 | |||
22 | inherit autotools pkgconfig gtk-doc | ||
23 | |||
24 | PACKAGES =+ "${PN}-tests" | ||
25 | |||
26 | EXTRA_OECONF += "--with-gstreamer-api=${GST_API_VERSION}" | ||
27 | |||
28 | PACKAGECONFIG ??= "drm \ | ||
29 | ${@base_contains("DISTRO_FEATURES", "opengl x11", "glx", "", d)} \ | ||
30 | ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)} \ | ||
31 | ${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)}" | ||
32 | |||
33 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm" | ||
34 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/mesa" | ||
35 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland" | ||
36 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" | ||
37 | |||
38 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" | ||
39 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" | ||
40 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a" | ||
41 | FILES_${PN}-tests = "${bindir}/*" | ||
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch new file mode 100644 index 00000000..9281b048 --- /dev/null +++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Install tests. | ||
2 | |||
3 | Upstream-Status: Inappropriate | ||
4 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
5 | |||
6 | --- | ||
7 | tests/Makefile.am | 4 ++-- | ||
8 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
9 | |||
10 | diff --git a/tests/Makefile.am b/tests/Makefile.am | ||
11 | index 2e7f191..8f65446 100644 | ||
12 | --- a/tests/Makefile.am | ||
13 | +++ b/tests/Makefile.am | ||
14 | @@ -1,4 +1,4 @@ | ||
15 | -noinst_PROGRAMS = \ | ||
16 | +bin_PROGRAMS = \ | ||
17 | simple-decoder \ | ||
18 | test-decode \ | ||
19 | test-display \ | ||
20 | @@ -9,7 +9,7 @@ noinst_PROGRAMS = \ | ||
21 | $(NULL) | ||
22 | |||
23 | if USE_GLX | ||
24 | -noinst_PROGRAMS += \ | ||
25 | +bin_PROGRAMS += \ | ||
26 | test-textures \ | ||
27 | $(NULL) | ||
28 | endif | ||
29 | -- | ||
30 | 1.7.10.4 | ||
31 | |||
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch new file mode 100644 index 00000000..c42e01fe --- /dev/null +++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Fix compilation of the Wayland backend when using GStreamer 0.10. | ||
2 | |||
3 | Upstream-Status: Submitted (https://bugzilla.gnome.org/show_bug.cgi?id=712282) | ||
4 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
5 | |||
6 | diff --git a/gst-libs/gst/vaapi/Makefile.am b/gst-libs/gst/vaapi/Makefile.am | ||
7 | index ab605e1..0a3fa38 100644 | ||
8 | --- a/gst-libs/gst/vaapi/Makefile.am | ||
9 | +++ b/gst-libs/gst/vaapi/Makefile.am | ||
10 | @@ -364,6 +364,7 @@ libgstvaapi_wayland_@GST_API_VERSION@_la_CFLAGS = \ | ||
11 | -I$(top_srcdir)/gst-libs \ | ||
12 | $(GLIB_CFLAGS) \ | ||
13 | $(GST_BASE_CFLAGS) \ | ||
14 | + $(top_builddir)/gst-libs/gst/video/libgstvaapi-videoutils.la \ | ||
15 | $(WAYLAND_CFLAGS) \ | ||
16 | $(LIBVA_WAYLAND_CFLAGS) \ | ||
17 | $(NULL) | ||