summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb27
-rw-r--r--common/recipes-kernel/linux/linux-intel.inc39
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb33
3 files changed, 41 insertions, 58 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
index 55015941..f34c6f54 100644
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -1,5 +1,5 @@
1 1
2require recipes-kernel/linux/linux-yocto.inc 2require linux-intel.inc
3 3
4# Skip processing of this recipe if it is not explicitly specified as the 4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying 5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
@@ -14,29 +14,4 @@ KBRANCH = "base-rt"
14SRCREV_machine ?= "cd65d037683c92be2c7dedc846f4bfd9ef84ecf4" 14SRCREV_machine ?= "cd65d037683c92be2c7dedc846f4bfd9ef84ecf4"
15SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be" 15SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be"
16 16
17SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.9.30"
21LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
22
23
24PV = "${LINUX_VERSION}+git${SRCPV}"
25
26KMETA = "kernel-meta"
27KCONF_BSP_AUDIT_LEVEL = "2"
28
29LINUX_KERNEL_TYPE = "preempt-rt" 17LINUX_KERNEL_TYPE = "preempt-rt"
30KERNEL_FEATURES_INTEL_COMMON ?= ""
31
32COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
33KMACHINE_core2-32-intel-common = "intel-core2-32"
34KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
35
36COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
37KMACHINE_corei7-64-intel-common = "intel-corei7-64"
38KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
39
40COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
41KMACHINE_i586-nlp-32-intel-common = "intel-quark"
42KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-intel.inc b/common/recipes-kernel/linux/linux-intel.inc
new file mode 100644
index 00000000..f3fbd59a
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-intel.inc
@@ -0,0 +1,39 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
5
6
7LINUX_VERSION ?= "4.9.30"
8LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
9
10PV = "${LINUX_VERSION}+git${SRCPV}"
11
12KMETA = "kernel-meta"
13KCONF_BSP_AUDIT_LEVEL = "2"
14
15KERNEL_FEATURES_INTEL_COMMON ?= ""
16
17COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
18KMACHINE_core2-32-intel-common = "intel-core2-32"
19KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
22KMACHINE_corei7-64-intel-common = "intel-corei7-64"
23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
26KMACHINE_i586-nlp-32-intel-common = "intel-quark"
27KERNEL_FEATURES_append_i586-nlp-32-intel-common = "features/qat/qat.scc"
28
29# Functionality flags
30KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
31KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
32
33do_compile_kernelmodules_append() {
34 rm -rf ${B}/drivers/net/wireless/intel/iwlwifi
35 rm -rf ${B}/net/mac80211
36 rm -rf ${B}/net/wireless
37}
38
39RDEPENDS_kernel-modules += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index 51506555..9e017aaa 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -1,44 +1,13 @@
1 1
2require recipes-kernel/linux/linux-yocto.inc 2require linux-intel.inc
3 3
4KBRANCH = "base" 4KBRANCH = "base"
5SRCREV_machine ?= "22a3e397584619839ec645c7378dc40bdd5ad2d1" 5SRCREV_machine ?= "22a3e397584619839ec645c7378dc40bdd5ad2d1"
6SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be" 6SRCREV_meta ?= "299f12a06ca1d6fd90b24450dae3b9f257a536be"
7 7
8SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
9 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
10
11LINUX_VERSION ?= "4.9.30"
12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}"
13
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16KMETA = "kernel-meta"
17KCONF_BSP_AUDIT_LEVEL = "2"
18
19KERNEL_FEATURES_INTEL_COMMON ?= ""
20
21COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
22KMACHINE_core2-32-intel-common = "intel-core2-32"
23KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
26KMACHINE_corei7-64-intel-common = "intel-corei7-64"
27KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
28
29COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
30KMACHINE_i586-nlp-32-intel-common = "intel-quark"
31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
32
33# For Crystalforest and Romley 8# For Crystalforest and Romley
34KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 9KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
35KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 10KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
36 11
37# For FRI2, NUC
38KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
39KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
40
41# Functionality flags 12# Functionality flags
42KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" 13KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
43KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
44KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"