summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend17
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend28
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.19.bbappend28
3 files changed, 0 insertions, 73 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
deleted file mode 100644
index dbf6841b..00000000
--- a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_core2-32-intel-common = "3.14.36"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "c33d39561807e1073ca412f1c771f43e4da75994"
6SRCREV_machine_core2-32-intel-common = "3fb54cf8f4c3254f628e6c4720fe3c731a9de0b2"
7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11LINUX_VERSION_corei7-64-intel-common = "3.14.36"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "c33d39561807e1073ca412f1c771f43e4da75994"
14SRCREV_machine_corei7-64-intel-common = "3fb54cf8f4c3254f628e6c4720fe3c731a9de0b2"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
deleted file mode 100644
index 2407e86d..00000000
--- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.14.39"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "c33d39561807e1073ca412f1c771f43e4da75994"
9SRCREV_machine_core2-32-intel-common = "bda175966009d5a94103559e6e6ae51279952f39"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.14.39"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "c33d39561807e1073ca412f1c771f43e4da75994"
17SRCREV_machine_corei7-64-intel-common = "bda175966009d5a94103559e6e6ae51279952f39"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
24KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
25
26# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
28KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.19.bbappend b/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
deleted file mode 100644
index 520fb2d5..00000000
--- a/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.19.5"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "a1ce9442fce7e94b2f0b6c1cf1997003b04fefd9"
9SRCREV_machine_core2-32-intel-common = "e152349de59b43b2a75f2c332b44171df461d5a0"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.19.5"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "a1ce9442fce7e94b2f0b6c1cf1997003b04fefd9"
17SRCREV_machine_corei7-64-intel-common = "e152349de59b43b2a75f2c332b44171df461d5a0"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
24KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
25
26# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
28KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"