summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-rt_3.14.bb')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.14.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb
new file mode 100644
index 00000000..d96870bf
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -0,0 +1,26 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH = "standard/preempt-rt/base"
4KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
5
6SRCREV_machine ?= "d31cfd2232d5f8287cad3fdeac4f8cc6b372a729"
7SRCREV_meta ?= "11e091dc40c53af6ea08ce491ae50fbb1b0b6377"
8
9SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
10
11LINUX_VERSION ?= "3.14.2"
12
13PV = "${LINUX_VERSION}+git${SRCPV}"
14
15KMETA = "meta"
16
17LINUX_KERNEL_TYPE = "preempt-rt"
18
19COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
20
21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
23KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
24KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
25KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
26KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"