summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/intel-ethernet/ixgbevf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/intel-ethernet/ixgbevf.bb')
-rw-r--r--common/recipes-kernel/intel-ethernet/ixgbevf.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/common/recipes-kernel/intel-ethernet/ixgbevf.bb b/common/recipes-kernel/intel-ethernet/ixgbevf.bb
new file mode 100644
index 00000000..bee601ba
--- /dev/null
+++ b/common/recipes-kernel/intel-ethernet/ixgbevf.bb
@@ -0,0 +1,44 @@
1SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="Intel 10-Gbps Ethernet driver for Magnolia Park"
3AUTHOR = "Ong Boon Leong"
4HOMEPAGE = "http://www.intel.com/network/connectivity/products/server_adapters.htm"
5SECTION = "kernel/network"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9PV = "4.1.2"
10PR = "r0"
11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/ixgbevf-${PV}.tar.gz"
13SRC_URI += "file://0001-ixgbevf-src-Makefile-change-make-install-to-make.patch"
14SRC_URI += "file://0002-ixgbevf_common.patch"
15
16SRC_URI[md5sum] = "f02ec46369d1ca949a1e9d2e0eb74d5f"
17SRC_URI[sha256sum] = "ab2824541f8a2d8f7b7d26ccbb46359ef551c5d4625fb333014e2b8023ac3ab6"
18
19S = "${WORKDIR}/${PN}-${PV}/src"
20SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
21
22EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" \
23 BUILD_ARCH="${TARGET_ARCH}" PREFIX="${D}" \
24 SYSTEM_MAP_FILE="${STAGING_KERNEL_BUILDDIR}/System.map-${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
25
26KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf"
27KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf"
28
29inherit module
30
31do_install_append () {
32 # Install scripts/set_irq_affinity
33 install -d ${D}/etc/network
34 install -m 0755 ${SCRIPT_DIR}/set_irq_affinity ${D}/etc/network
35}
36
37#SSTATE_DUPWHITELIST += "${STAGING_DIR_HOST}/lib/modules/${KERNEL_VERSION}/"
38
39PACKAGES += "${PN}-script"
40
41FILES_${PN}-script += "/etc/network/set_irq_affinity"
42
43#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
44INSANE_SKIP_${PN} = "installed-vs-shipped"