summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch')
-rw-r--r--common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch b/common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
new file mode 100644
index 00000000..88f5335a
--- /dev/null
+++ b/common/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
@@ -0,0 +1,40 @@
1From 09c7a5afa76530a3720d97726f2b372f72b0af08 Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Wed, 22 Jun 2016 11:18:37 +0800
4Subject: [PATCH] ixgbe: src/Makefile: change make install to make
5 modules_install
6
7Per guideline from Linux Documentation at
8Documentation/kbuild/modules.txt
9the correct target is "modules_install" not "install".
10
11Upstream-Status: Inappropriate [It is tarball released by Intel Network
12driver group]
13
14---
15 src/Makefile | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/Makefile b/Makefile
19index 852becb..480ecee 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -136,7 +136,7 @@ clean:
23 @-rm -rf *.${MANSECTION}.gz *.ko
24
25 # Install the modules and manpage
26-install: default manfile
27+modules_install: default manfile
28 @echo "Copying manpages..."
29 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
30 @echo "Installing modules..."
31@@ -191,6 +191,6 @@ help:
32 @echo ' Other variables may be available for tuning make process, see'
33 @echo ' Kernel Kbuild documentation for more information'
34
35-.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
36+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
37
38 endif # ifneq($(KERNELRELEASE),)
39--
402.8.3