summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/intel-ethernet/ixgbe.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/intel-ethernet/ixgbe.bb')
-rw-r--r--common/recipes-kernel/intel-ethernet/ixgbe.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-kernel/intel-ethernet/ixgbe.bb b/common/recipes-kernel/intel-ethernet/ixgbe.bb
new file mode 100644
index 00000000..5b6f0311
--- /dev/null
+++ b/common/recipes-kernel/intel-ethernet/ixgbe.bb
@@ -0,0 +1,43 @@
1SUMMARY="ixgbe kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="Intel 10-Gbps Ethernet driver for Magnolia Park"
3AUTHOR = "Ong Boon Leong"
4HOMEPAGE = "http://www.intel.com/network/connectivity/products/server_adapters.htm"
5SECTION = "kernel/network"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9PV = "5.1.3"
10PR = "r0"
11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/ixgbe-${PV}.tar.gz"
13SRC_URI += "file://0001-ixgbe-src-Makefile-change-make-install-to-make.patch"
14
15SRC_URI[md5sum] = "ae35ed547aa6a5087672c3f70ce1e676"
16SRC_URI[sha256sum] = "9f537d79bddf0a087a17af632d57812d26d26bcfebbd4bdcf10df656ff055bb4"
17
18S = "${WORKDIR}/${PN}-${PV}/src"
19SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
20
21EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" \
22 BUILD_ARCH="${TARGET_ARCH}" PREFIX="${D}" \
23 SYSTEM_MAP_FILE="${STAGING_KERNEL_BUILDDIR}/System.map-${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
24
25KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbe"
26KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbe"
27
28inherit module
29
30do_install_append () {
31 # Install scripts/set_irq_affinity
32 install -d ${D}/etc/network
33 install -m 0755 ${SCRIPT_DIR}/set_irq_affinity ${D}/etc/network
34}
35
36#SSTATE_DUPWHITELIST += "${STAGING_DIR_HOST}/lib/modules/${KERNEL_VERSION}/"
37
38PACKAGES += "${PN}-script"
39
40FILES_${PN}-script += "/etc/network/set_irq_affinity"
41
42#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
43INSANE_SKIP_${PN} = "installed-vs-shipped"