diff options
Diffstat (limited to 'common/recipes-graphics')
-rw-r--r-- | common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend index 6bfa9686..b92831d3 100644 --- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend +++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend | |||
@@ -6,13 +6,13 @@ | |||
6 | python __anonymous () { | 6 | python __anonymous () { |
7 | import re | 7 | import re |
8 | xserver = d.getVar('XSERVER', True) | 8 | xserver = d.getVar('XSERVER', True) |
9 | if 'emgd-driver-bin' in xserver.split(' '): | 9 | if xserver and 'emgd-driver-bin' in xserver.split(' '): |
10 | extra_oeconf = d.getVar('EXTRA_OECONF', True).split() | 10 | extra_oeconf = d.getVar('EXTRA_OECONF', True).split() |
11 | take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] | 11 | take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] |
12 | put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] | 12 | put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] |
13 | pattern = re.compile("--with-egl-platforms") | 13 | pattern = re.compile("--with-egl-platforms") |
14 | new_extra_oeconf = [ ] | 14 | new_extra_oeconf = [ ] |
15 | for i in extra_oeconf: | 15 | for i in extra_oeconf: |
16 | if ( i not in take_out ) and ( not pattern.match(i)): | 16 | if ( i not in take_out ) and ( not pattern.match(i)): |
17 | new_extra_oeconf.append(i) | 17 | new_extra_oeconf.append(i) |
18 | for i in put_in: | 18 | for i in put_in: |