summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch')
-rw-r--r--common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch b/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch
new file mode 100644
index 00000000..59a54ce9
--- /dev/null
+++ b/common/recipes-extended/openssl-qat/openssl-qat/openssl_qat-pass-oe_ldflags-to-linker.patch
@@ -0,0 +1,40 @@
1From accc6c251cafdb3332db946d543952e2cf0698cd Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Sat, 20 Jun 2015 00:31:31 +0800
4Subject: [PATCH] openssl_qat: pass oe_ldflags to linker
5
6Upstream-Status: Inappropriate [open-embedded]
7
8(Taken from meta/recipes-connectivity/openssl/openssl/oe-ldflags.patch
9 rev: 5dd1d7566964c90d33c0c44f569d9336fb0724ce)
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 Makefile.shared | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/Makefile.shared b/Makefile.shared
17index e753f44..fcdcb9e 100644
18--- a/Makefile.shared
19+++ b/Makefile.shared
20@@ -92,7 +92,7 @@ CALC_VERSIONS= \
21 LINK_APP= \
22 ( $(SET_X); \
23 LIBDEPS="$${LIBDEPS:-$(LIBDEPS)}"; \
24- LDCMD="$${LDCMD:-$(CC)}"; LDFLAGS="$${LDFLAGS:-$(CFLAGS)}"; \
25+ LDCMD="$${LDCMD:-$(CC)}"; LDFLAGS="$(OE_LDFLAGS) $${LDFLAGS:-$(CFLAGS)}"; \
26 LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
27 LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
28 LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
29@@ -102,7 +102,7 @@ LINK_SO= \
30 ( $(SET_X); \
31 LIBDEPS="$${LIBDEPS:-$(LIBDEPS)}"; \
32 SHAREDCMD="$${SHAREDCMD:-$(CC)}"; \
33- SHAREDFLAGS="$${SHAREDFLAGS:-$(CFLAGS) $(SHARED_LDFLAGS)}"; \
34+ SHAREDFLAGS="$(OE_LDFLAGS) $${SHAREDFLAGS:-$(CFLAGS) $(SHARED_LDFLAGS)}"; \
35 LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
36 LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
37 LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
38--
391.7.9.5
40