summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
new file mode 100644
index 00000000..e17d80d1
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -0,0 +1,42 @@
1From 4cdcb5ea4af9677677a007c4f9b286948123be87 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 2 Sep 2016 15:48:52 +0800
4Subject: [PATCH] dpdk: fix for parellel make issue
5
6To make sure that the path of libraries should be correct and
7libraries will be build before, And available at the time of
8linking example apps.
9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11---
12 examples/Makefile | 1 +
13 examples/ethtool/ethtool-app/Makefile | 1 +
14 2 files changed, 2 insertions(+)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index 18b41b9..c7c2beb 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
21 ifneq ($(ICP_ROOT),)
22 DIRS-y += dpdk_qat
23 endif
24+DEPDIRS-y += examples/ethtool/lib
25 DIRS-y += ethtool
26 DIRS-y += exception_path
27 DIRS-y += helloworld
28diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile
29index 09c66ad..ec068e6 100644
30--- a/examples/ethtool/ethtool-app/Makefile
31+++ b/examples/ethtool/ethtool-app/Makefile
32@@ -47,6 +47,7 @@ SRCS-y := main.c ethapp.c
33 CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib
34 CFLAGS += $(WERROR_FLAGS)
35
36+LDLIBS += -L$(ETHTOOL_LIB_PATH)/
37 LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
38 LDLIBS += -lrte_ethtool
39
40--
411.9.1
42