summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch
new file mode 100644
index 00000000..75bb517d
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch
@@ -0,0 +1,43 @@
1From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Fri, 24 Jul 2015 23:57:17 +0800
4Subject: [PATCH] dpdk: point to the right include and lib path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the right location of qat
9lac headers and library.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/dpdk_qat/Makefile | 7 ++-----
14 1 file changed, 2 insertions(+), 5 deletions(-)
15
16diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile
17index f1e06a1..5b906f7 100644
18--- a/examples/dpdk_qat/Makefile
19+++ b/examples/dpdk_qat/Makefile
20@@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c
21
22 CFLAGS += -O3
23 CFLAGS += $(WERROR_FLAGS)
24-CFLAGS += -I$(ICP_ROOT)/quickassist/include \
25- -I$(ICP_ROOT)/quickassist/include/lac \
26- -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include
27+CFLAGS += -I$(ICP_LAC_API_DIR)
28
29 # From CRF 1.2 driver, library was renamed to libicp_qa_al.a
30 ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),)
31 ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a
32 else
33-ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a
34+ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a
35 endif
36
37-LDLIBS += -L$(ICP_ROOT)/build
38 LDLIBS += $(ICP_LIBRARY_PATH) \
39 -lz \
40 -losal \
41--
421.7.9.5
43