summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch
new file mode 100644
index 00000000..4254d073
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch
@@ -0,0 +1,30 @@
1From 8ce0e3249942a90f733bb2113e70e5a90ae67b00 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Thu, 21 Jul 2016 05:53:52 +0800
4Subject: [PATCH 1/2] dpdk: fix compilation with dynamic libs
5
6Upstream-Status: Inappropriate [Configuration]
7
8Ensure that the correct cflags are being used.
9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11---
12 mk/rte.lib.mk | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/mk/rte.lib.mk b/mk/rte.lib.mk
16index 8f7e021..42610c9 100644
17--- a/mk/rte.lib.mk
18+++ b/mk/rte.lib.mk
19@@ -70,7 +70,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
20
21 ifeq ($(LINK_USING_CC),1)
22 # Override the definition of LD here, since we're linking with CC
23-LD := $(CC) $(CPU_CFLAGS)
24+LD := $(CC) $(CPU_CFLAGS) $(EXTRA_CFLAGS)
25 _CPU_LDFLAGS := $(call linkerprefix,$(CPU_LDFLAGS))
26 override EXTRA_LDFLAGS := $(call linkerprefix,$(EXTRA_LDFLAGS))
27 else
28--
291.9.1
30