summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/microcode/iucode-tool_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core/microcode/iucode-tool_1.3.bb')
-rw-r--r--common/recipes-core/microcode/iucode-tool_1.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/iucode-tool_1.3.bb b/common/recipes-core/microcode/iucode-tool_1.3.bb
new file mode 100644
index 00000000..35bcd7b6
--- /dev/null
+++ b/common/recipes-core/microcode/iucode-tool_1.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Update Intel CPU microcode"
2
3DESCRIPTION = "iucode_tool is a program to manipulate Intel i686 and X86-64\
4 processor microcode update collections, and to use the kernel facilities to\
5 update the microcode on Intel system processors. It can load microcode data\
6 files in text and binary format, sort, list and filter the microcode updates\
7 contained in these files, write selected microcode updates to a new file in\
8 binary format, or upload them to the kernel. \
9 It operates on microcode data downloaded directly from Intel:\
10 http://feeds.downloadcenter.intel.com/rss/?p=2371\
11"
12HOMEPAGE = "https://gitlab.com/iucode-tool/"
13BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?ordering=normal;archive=0;src=iucode-tool;repeatmerged=0"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
17 file://iucode_tool.c;beginline=1;endline=15;md5=f65c2be08bfd462331cadff25869588e"
18
19SRC_URI = "https://gitlab.com/iucode-tool/releases/raw/master/iucode-tool_${PV}.tar.xz"
20SRC_URI[md5sum] = "ad5aa3ed5eee2f9ef58a291fe7ca711d"
21SRC_URI[sha256sum] = "c6e134fc63ac7e765f729c500adc9e154da57b02e991be35b421acf9c7eb0ea9"
22
23S = "${WORKDIR}/iucode_tool-${PV}"
24
25inherit autotools
26
27BBCLASSEXTEND = "native"
28
29COMPATIBLE_HOST = "(i.86|x86_64).*-linux"