summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch b/common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch
new file mode 100644
index 00000000..c8867a24
--- /dev/null
+++ b/common/recipes-bsp/systemd-boot/systemd-boot/0001-sd-boot-Link-RMC-libraries-into-bootloader.patch
@@ -0,0 +1,31 @@
1From b7775f24928fca01600cac1077ff3f215aa6362d Mon Sep 17 00:00:00 2001
2From: Jianxun Zhang <jianxun.zhang@linux.intel.com>
3Date: Sat, 21 May 2016 18:52:07 -0700
4Subject: [PATCH 1/3] sd-boot: Link RMC libraries into bootloader
5
6Add two RMC libraries into bootloader binary. EFI stub is not changed
7until we really need rmc in stub.
8
9Upstream-Status: Pending
10
11Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com>
12---
13 Makefile.am | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/Makefile.am b/Makefile.am
17index 305099a..ff21ebd 100644
18--- a/Makefile.am
19+++ b/Makefile.am
20@@ -2802,7 +2802,7 @@ $(top_builddir)/src/boot/efi/%.o: $(top_srcdir)/src/boot/efi/%.c $(addprefix $(t
21
22 $(systemd_boot_solib): $(systemd_boot_objects)
23 $(AM_V_CCLD)$(LD) $(efi_ldflags) $(systemd_boot_objects) \
24- -o $@ -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name); \
25+ -o $@ -lefi -lgnuefi -lrmclefi -lrsmpefi $(shell $(CC) -print-libgcc-file-name); \
26 nm -D -u $@ | grep ' U ' && exit 1 || :
27
28 $(systemd_boot): $(systemd_boot_solib)
29--
302.7.4
31