summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/systemd-boot/systemd-boot.bbappend')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
new file mode 100644
index 00000000..f42434c1
--- /dev/null
+++ b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
@@ -0,0 +1,20 @@
1DEPENDS += "rmc"
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-boot:"
4
5EXTRA_OEMAKE += 'EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc/efi -DRMC_EFI"'
6
7# Pin systemd revision down for systemd-boot recipe.
8# Patches could not be applied cleanly when systemd in OE is updated,
9# though we don't expect a lot of changes could happen in bootloader.
10# RMC is designed to support a large number of types of boards, so we
11# should do explicit update with validation to prevent regression even
12# resolving conflicts for a new tip could be done in a short time.
13
14# Revision: systemd 230 in OE
15SRCREV = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba"
16
17SRC_URI += "file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \
18 file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \
19 file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \
20 "