summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gummiboot/gummiboot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gummiboot/gummiboot_git.bb')
-rw-r--r--common/recipes-bsp/gummiboot/gummiboot_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/common/recipes-bsp/gummiboot/gummiboot_git.bb b/common/recipes-bsp/gummiboot/gummiboot_git.bb
new file mode 100644
index 00000000..871a9500
--- /dev/null
+++ b/common/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools
10inherit deploy
11
12PV = "33"
13PR = "r0"
14SRCREV = "cbc63ae9d6161fe6412f0457e72a276f5acb6e2a"
15SRC_URI = "git://anongit.freedesktop.org/gummiboot \
16 file://0001-configure.ac-Add-option-to-disable-configuring-the-B.patch \
17 file://0002-configure.ac-Use-AC_CHECK_HEADER-to-detect-the-efi-i.patch \
18 file://0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch \
19 file://0004-configure.ac-Allow-for-more-than-just-i686-for-ia32.patch \
20 file://0005-Auto-detect-both-x64-and-ia32-boot-.efi-payloads.patch \
21 file://0006-Add-32-bit-compatible-rdtsc-asm.patch"
22
23S = "${WORKDIR}/git"
24
25EXTRA_OECONF = "--disable-biostest"
26EXTRA_OEMAKE = "INCDIR=${STAGING_INCDIR} GNUEFI_LDS_DIR=${STAGING_LIBDIR} \
27 GNUEFI_LIBS='-L ${STAGING_LIBDIR}'"
28
29do_deploy () {
30 install ${S}/gummiboot*.efi ${DEPLOYDIR}/
31}
32addtask deploy before do_build after do_compile