summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch')
-rw-r--r--common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch b/common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch
new file mode 100644
index 00000000..7a51490c
--- /dev/null
+++ b/common/recipes-bsp/gummiboot/files/0003-Makefile.am-Allow-for-user-override-of-EFI-include-d.patch
@@ -0,0 +1,39 @@
1From 8d1e561ef06889c7dd5943c5be2045c6cf98b14c Mon Sep 17 00:00:00 2001
2Message-Id: <8d1e561ef06889c7dd5943c5be2045c6cf98b14c.1367382591.git.dvhart@linux.intel.com>
3In-Reply-To: <c72599a7bd46c22d296c59dbd13f138503350d2f.1367382591.git.dvhart@linux.intel.com>
4References: <c72599a7bd46c22d296c59dbd13f138503350d2f.1367382591.git.dvhart@linux.intel.com>
5From: Darren Hart <dvhart@linux.intel.com>
6Date: Tue, 30 Apr 2013 21:18:51 -0700
7Subject: [PATCH 3/4] Makefile.am: Allow for user override of EFI include dir
8
9Enable cross-compiling by allowing the user to specify an alternative to
10the /usr/include directory for the EFI includes. Add a variable INCDIR
11defaulting to /usr/include, but still allowing the user to provide their
12own value.
13
14Signed-off-by: Darren Hart <dvhart@linux.intel.com>
15---
16 Makefile.am | 5 +++--
17 1 files changed, 3 insertions(+), 2 deletions(-)
18
19diff --git a/Makefile.am b/Makefile.am
20index 22e314d..2611971 100644
21--- a/Makefile.am
22+++ b/Makefile.am
23@@ -72,10 +72,11 @@ CLEANFILES += man/gummiboot.8
24 efi_loadername = gummiboot$(MACHINE_TYPE_NAME).efi
25 efi_sources = src/efi/gummiboot.c
26
27+INCDIR := /usr/include
28 efi_cppflags = \
29 -I$(top_builddir) -include config.h \
30- -I/usr/include/efi \
31- -I/usr/include/efi/$(ARCH)
32+ -I$(INCDIR)/efi \
33+ -I$(INCDIR)/efi/$(ARCH)
34
35 efi_cflags = \
36 -Wall \
37--
381.7.5.4
39