summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch')
-rw-r--r--common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch b/common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch
new file mode 100644
index 00000000..9ed0a5e0
--- /dev/null
+++ b/common/recipes-bsp/gummiboot/files/0001-configure.ac-Add-option-to-disable-configuring-the-B.patch
@@ -0,0 +1,39 @@
1From c72599a7bd46c22d296c59dbd13f138503350d2f Mon Sep 17 00:00:00 2001
2Message-Id: <c72599a7bd46c22d296c59dbd13f138503350d2f.1367382591.git.dvhart@linux.intel.com>
3From: Darren Hart <dvhart@linux.intel.com>
4Date: Tue, 30 Apr 2013 21:11:17 -0700
5Subject: [PATCH 1/4] configure.ac: Add option to disable configuring the BIOS
6 test
7
8When cross-compiling, AC_CHECK_FILE aborts configure. Provide a means to
9avoid even attempting to configure the BIOS test.
10
11Signed-off-by: Darren Hart <dvhart@linux.intel.com>
12---
13 configure.ac | 10 +++++++---
14 1 files changed, 7 insertions(+), 3 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index efa0e54..524060c 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -66,9 +66,13 @@ AC_SUBST([ARCH])
21 AC_SUBST([MACHINE_TYPE_NAME])
22
23 # test bios
24-AC_CHECK_FILE([/usr/lib/qemu-bios], [BIOS=/usr/lib/qemu-bios])
25-AC_CHECK_FILE([/usr/share/qemu-ovmf/bios], [BIOS=/usr/share/qemu-ovmf/bios])
26-AC_SUBST([BIOS])
27+AC_ARG_ENABLE(biostest, AS_HELP_STRING([--disable-biostest], [disable building BIOS test]))
28+if test "x$enable_biostest" != "xno"; then
29+ AC_CHECK_FILE([/usr/lib/qemu-bios], [BIOS=/usr/lib/qemu-bios])
30+ AC_CHECK_FILE([/usr/share/qemu-ovmf/bios], [BIOS=/usr/share/qemu-ovmf/bios])
31+ AC_SUBST([BIOS])
32+fi
33+AM_CONDITIONAL(ENABLE_BIOSTEST, [test "x$enable_biostest" = "xyes"])
34
35 # ------------------------------------------------------------------------------
36 dnl Compile EFI stuff is so tricky that it's probably better to check for the
37--
381.7.5.4
39