summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/grub/grub_1.98.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/grub/grub_1.98.bb')
-rw-r--r--common/recipes-bsp/grub/grub_1.98.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/common/recipes-bsp/grub/grub_1.98.bb b/common/recipes-bsp/grub/grub_1.98.bb
new file mode 100644
index 00000000..b9d04fc5
--- /dev/null
+++ b/common/recipes-bsp/grub/grub_1.98.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10PRIORITY = "optional"
11
12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15RDEPENDS = "diffutils"
16PR = "r0"
17
18SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://uninit-shdr-fix.patch;apply=yes \
20 file://grub-install.in.patch;apply=yes \
21 file://40_custom"
22
23inherit autotools
24inherit gettext
25
26EXTRA_OECONF = "--with-platform=pc --target=i386"
27
28do_configure() {
29 oe_runconf
30}
31
32python __anonymous () {
33 import re
34 host = bb.data.getVar('HOST_SYS', d, 1)
35 if not re.match('x86.64.*-linux', host):
36 raise bb.parse.SkipPackage("incompatible with host %s" % host)
37}
38
39do_install_append () {
40 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
41}
42
43FILES_${PN}-doc = "${datadir}"
44FILES_${PN} = "/usr /etc"
45