summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/grub/grub_1.98.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/grub/grub_1.98.bb')
-rw-r--r--common/recipes-bsp/grub/grub_1.98.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/common/recipes-bsp/grub/grub_1.98.bb b/common/recipes-bsp/grub/grub_1.98.bb
deleted file mode 100644
index 1b3040b4..00000000
--- a/common/recipes-bsp/grub/grub_1.98.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10PRIORITY = "optional"
11
12LICENSE = "GPLv3"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15RDEPENDS = "diffutils freetype"
16PR = "r1"
17
18SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
19 file://uninit-shdr-fix.patch;apply=yes \
20 file://grub-install.in.patch;apply=yes \
21 file://gentrigtables-compile-fix.patch;apply=yes \
22 file://40_custom"
23
24inherit autotools
25inherit gettext
26
27EXTRA_OECONF = "--with-platform=pc --target=i386 --disable-grub-mkfont"
28
29do_configure() {
30 oe_runconf
31}
32
33python __anonymous () {
34 import re
35 host = bb.data.getVar('HOST_SYS', d, 1)
36 if not re.match('x86.64.*-linux', host):
37 raise bb.parse.SkipPackage("incompatible with host %s" % host)
38}
39
40do_install_append () {
41 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
42}
43
44FILES_${PN}-doc = "${datadir}"
45FILES_${PN} = "/usr /etc"
46