summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb')
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb b/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
new file mode 100644
index 00000000..505c4887
--- /dev/null
+++ b/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Libraries for producing EFI binaries"
2HOMEPAGE = "http://sourceforge.net/projects/gnu-efi/"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666"
6
7PR = "r0"
8
9SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0u.orig.tar.gz \
10 file://parallel-make.patch \
11 file://parallel-make-archives.patch \
12 "
13SRC_URI[md5sum] = "d15d3c700e79a1e2938544d73edc572d"
14SRC_URI[sha256sum] = "3c0d450d5829204ca05dcb3b2aae772e52c379b7c7e09146759c6315606f934e"
15
16COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
17
18S = "${WORKDIR}/gnu-efi-3.0"
19
20def gnu_efi_arch(d):
21 import re
22 tarch = d.getVar("TARGET_ARCH", True)
23 if re.match("i[3456789]86", tarch):
24 return "ia32"
25 return tarch
26
27EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
28 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}'\
29 "
30
31do_install() {
32 oe_runmake install INSTALLROOT="${D}"
33}
34
35FILES_${PN} += "${libdir}/*.lds"