summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/amt/lms_7.1.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/amt/lms_7.1.20.bb')
-rw-r--r--common/recipes-bsp/amt/lms_7.1.20.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-bsp/amt/lms_7.1.20.bb b/common/recipes-bsp/amt/lms_7.1.20.bb
new file mode 100644
index 00000000..3fd8c278
--- /dev/null
+++ b/common/recipes-bsp/amt/lms_7.1.20.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Intel Local Manageability Service allows applications \
2to access the Intel Active Management Technology (AMT) firmware via \
3the Intel Management Engine Interface (MEI)."
4HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers"
5
6LICENSE = "Modified BSD"
7
8PR = "r0"
9SRC_URI = "http://software.intel.com/file/37962 \
10 file://atnetworktool-printf-fix.patch \
11 file://readlink-declaration.patch"
12
13COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b"
16
17SRC_URI[md5sum] = "687b76e78bfdbcf567c0e842c1fe240a"
18SRC_URI[sha256sum] = "cc0457f0044e924794bb1aeae9a72c28666a525cd8a963d0d92970222946e75b"
19
20inherit autotools update-rc.d
21
22INITSCRIPT_NAME = "lms"
23INITSCRIPT_PARAMS = "defaults"
24
25PV_SUB = "25"
26
27do_unpack2() {
28 # The downloaded 37962 filename is actually lms+7.1.20.25.zip.
29 # It contains lms-7.1.20-25.tar.gz.
30 # It contains lms-7.1.20-25.tar.gz untars to lms-7.1.20
31 mv ${WORKDIR}/37962 ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip
32 unzip -o ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip
33 mv ${WORKDIR}/${PN}-${PV}/outputdir/${PN}-${PV}-${PV_SUB}.tar.gz ${WORKDIR}/
34 cd ${WORKDIR}
35 tar -xvzf ${PN}-${PV}-${PV_SUB}.tar.gz
36}
37
38addtask unpack2 after do_unpack before do_patch
39
40do_install_append () {
41 install -d ${D}${sysconfdir}/init.d
42 install -m 0755 ${WORKDIR}/${PN}-${PV}/scripts/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
43}