summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/amt/lms7_7.1.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/amt/lms7_7.1.20.bb')
-rw-r--r--common/recipes-bsp/amt/lms7_7.1.20.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/recipes-bsp/amt/lms7_7.1.20.bb b/common/recipes-bsp/amt/lms7_7.1.20.bb
new file mode 100644
index 00000000..2c6a29e1
--- /dev/null
+++ b/common/recipes-bsp/amt/lms7_7.1.20.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Intel Local Manageability Service allows applications \
2to access the Intel Active Management Technology (AMT) firmware via \
3the Intel Management Engine Interface (MEI)."
4HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers"
5
6LICENSE = "BSD_LMS"
7
8PR = "r0"
9BPN="lms"
10PV_SUB = "25"
11SRC_URI = "http://software.intel.com/file/37962;downloadfilename=${BPN}+${PV}.${PV_SUB}.zip \
12 file://atnetworktool-printf-fix.patch \
13 file://readlink-declaration.patch"
14
15COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b"
18
19SRC_URI[md5sum] = "687b76e78bfdbcf567c0e842c1fe240a"
20SRC_URI[sha256sum] = "cc0457f0044e924794bb1aeae9a72c28666a525cd8a963d0d92970222946e75b"
21
22inherit autotools update-rc.d
23
24INITSCRIPT_NAME = "lms7"
25INITSCRIPT_PARAMS = "defaults"
26
27do_unpack2() {
28 cd ${WORKDIR}
29 tar -xvzf ${WORKDIR}/outputdir/lms-${PV}-${PV_SUB}.tar.gz
30}
31
32addtask unpack2 after do_unpack before do_patch
33
34do_install_append () {
35 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7
36 install -d ${D}${sysconfdir}/init.d
37 mv ${D}${sysconfdir}/rc.d/init.d/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
38 sed -i 's/^NAME=lms/NAME=lms7/' ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
39 rmdir ${D}${datadir} || :
40}