summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
new file mode 100644
index 00000000..d2e1c16b
--- /dev/null
+++ b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -0,0 +1,9 @@
1PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
2
3do_compile_append_intel-x86-common() {
4 ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
5}
6
7do_deploy_append_intel-x86-common() {
8 install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR}
9}