summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb2
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch24
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest8
3 files changed, 34 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
index b8d5d3d5..562bd740 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
14 file://0004-disable-werror.patch;patchdir=../ \ 14 file://0004-disable-werror.patch;patchdir=../ \
15 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \ 15 file://0005-point-to-correct-location-of-ngraph-headers.patch;patchdir=../ \
16 file://0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \ 16 file://0001-Install-clDNN-plugin-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
17 file://0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch;patchdir=../ \
17 file://run-ptest \ 18 file://run-ptest \
18 " 19 "
19SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf" 20SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
@@ -73,6 +74,7 @@ do_install_ptest_base_prepend() {
73 # Create a dummy Makefile so installation doesn't fail. 74 # Create a dummy Makefile so installation doesn't fail.
74 touch ${WORKDIR}/Makefile 75 touch ${WORKDIR}/Makefile
75 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/ 76 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
77 mv ${D}${libdir}/libmock_engine.so ${D}${PTEST_PATH}/
76} 78}
77 79
78FILES_${PN}-dev = "${includedir} \ 80FILES_${PN}-dev = "${includedir} \
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch
new file mode 100644
index 00000000..74c260ab
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-mock_engine-install-to-CMAKE_INSTALL_LIBDIR.patch
@@ -0,0 +1,24 @@
1From 34f3eb50ad5063bbf00ade1e9281e3c238d3216e Mon Sep 17 00:00:00 2001
2From: Chin Huat Ang <chin.huat.ang@intel.com>
3Date: Wed, 16 Oct 2019 13:06:26 +0800
4Subject: [PATCH] mock_engine: install to CMAKE_INSTALL_LIBDIR
5
6Upstream-Status: Pending
7Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
8---
9 inference-engine/tests/mock_engine/CMakeLists.txt | 2 ++
10 1 file changed, 2 insertions(+)
11
12diff --git a/inference-engine/tests/mock_engine/CMakeLists.txt b/inference-engine/tests/mock_engine/CMakeLists.txt
13index a0f77cf..753c901 100644
14--- a/inference-engine/tests/mock_engine/CMakeLists.txt
15+++ b/inference-engine/tests/mock_engine/CMakeLists.txt
16@@ -38,3 +38,5 @@ target_compile_definitions(${TARGET_NAME} PRIVATE IMPLEMENT_INFERENCE_ENGINE_API
17 set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD 11)
18 set_property(TARGET ${TARGET_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
19 set_property(TARGET ${TARGET_NAME} PROPERTY COMPILE_PDB_NAME ${TARGET_NAME})
20+
21+install(TARGETS ${TARGET_NAME} EXPORT ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
22--
232.7.4
24
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
index 77310f9f..92f238a9 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/run-ptest
@@ -1,5 +1,13 @@
1#!/bin/sh 1#!/bin/sh
2 2
3# InferenceEngineUnitTests requires libmock_engine.so, since they are
4# installed in the same directory we will need to set LD_LIBRARY_PATH
5# so that libmock_engine.so is picked up correctly. We also assume that
6# this script is only execute within the same directory where it is
7# installed.
8
9export LD_LIBRARY_PATH=.
10
3./InferenceEngineUnitTests |sed \ 11./InferenceEngineUnitTests |sed \
4 -e 's|\[.*OK.*\]\(.*\)|PASS:\1|' \ 12 -e 's|\[.*OK.*\]\(.*\)|PASS:\1|' \
5 -e 's|\[.*FAILED.*\]\(.*\)|FAIL:\1|' 13 -e 's|\[.*FAILED.*\]\(.*\)|FAIL:\1|'