summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
index a7db09ae..b8d5d3d5 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r2.bb
@@ -27,7 +27,7 @@ SRC_URI[ma2x8x.sha256sum] = "93640eb13e235d3f71a83cd503c36ff8a63235349e1f528d903
27LICENSE = "Apache-2.0" 27LICENSE = "Apache-2.0"
28LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 28LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
29 29
30inherit cmake ptest 30inherit cmake ptest python3native
31 31
32S = "${WORKDIR}/git/inference-engine" 32S = "${WORKDIR}/git/inference-engine"
33 33
@@ -38,7 +38,7 @@ EXTRA_OECMAKE += " \
38 -DENABLE_SAMPLES_CORE=1 \ 38 -DENABLE_SAMPLES_CORE=1 \
39 -DENABLE_PLUGIN_RPATH=0 \ 39 -DENABLE_PLUGIN_RPATH=0 \
40 -DENABLE_GNA=0 \ 40 -DENABLE_GNA=0 \
41 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ 41 -DPYTHON_EXECUTABLE=${PYTHON} \
42 -DTHREADING=TBB \ 42 -DTHREADING=TBB \
43 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \ 43 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
44 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \ 44 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
@@ -65,6 +65,7 @@ COMPATIBLE_HOST_libc-musl = "null"
65 65
66PACKAGECONFIG ?= "" 66PACKAGECONFIG ?= ""
67PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime" 67PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
68PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3"
68 69
69do_install_ptest_base_prepend() { 70do_install_ptest_base_prepend() {
70 # While not a Makefile based project that strictly falls into the category of 71 # While not a Makefile based project that strictly falls into the category of
@@ -74,9 +75,6 @@ do_install_ptest_base_prepend() {
74 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/ 75 mv ${D}${bindir}/InferenceEngineUnitTests ${D}${PTEST_PATH}/
75} 76}
76 77
77# Move inference engine samples into a separate package
78PACKAGES =+ "${PN}-samples"
79
80FILES_${PN}-dev = "${includedir} \ 78FILES_${PN}-dev = "${includedir} \
81 ${libdir}/cmake \ 79 ${libdir}/cmake \
82 ${libdir}/libinference_engine.so \ 80 ${libdir}/libinference_engine.so \
@@ -86,4 +84,12 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
86 ${datadir}/openvino \ 84 ${datadir}/openvino \
87 " 85 "
88 86
87# Move inference engine samples into a separate package
88PACKAGES =+ "${PN}-samples"
89
89FILES_${PN}-samples = "${bindir}" 90FILES_${PN}-samples = "${bindir}"
91
92# Package for inference engine python API
93PACKAGES =+ "${PN}-${PYTHON_PN}"
94
95FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"