summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc10
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc1
-rw-r--r--recipes-bsp/systemd-boot/systemd-boot_%.bbappend10
3 files changed, 10 insertions, 11 deletions
diff --git a/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc b/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc
index 1172d53d..aea22499 100644
--- a/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc
+++ b/recipes-bsp/systemd-boot/systemd-boot/rmc-boot.inc
@@ -1,3 +1,13 @@
1# Pin systemd revision down for systemd-boot recipe.
2# Patches could not be applied cleanly when systemd in OE is updated,
3# though we don't expect a lot of changes could happen in bootloader.
4# RMC is designed to support a large number of types of boards, so we
5# should do explicit update with validation to prevent regression even
6# resolving conflicts for a new tip could be done in a short time.
7
8# Revision: systemd v232 in OE
9SRCREV_intel-x86-common = "a1e2ef7ec912902d8142e7cb5830cbfb47dba86c"
10
1DEPENDS_append_intel-x86-common = " rmc rmc-efi" 11DEPENDS_append_intel-x86-common = " rmc rmc-efi"
2 12
3EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc -DRMC_EFI"' 13EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc -DRMC_EFI"'
diff --git a/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc b/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc
index fcce6ce1..788e57af 100644
--- a/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc
+++ b/recipes-bsp/systemd-boot/systemd-boot/systemd-boot.inc
@@ -2,6 +2,5 @@ EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/
2 2
3SRC_URI_append_intel-x86-common = " \ 3SRC_URI_append_intel-x86-common = " \
4 file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ 4 file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
5 file://0001-sd-boot-stub-check-LoadOptions-contains-data.patch \
6 " 5 "
7 6
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
index 557c0493..48968116 100644
--- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -1,15 +1,5 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:" 1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:"
2 2
3# Pin systemd revision down for systemd-boot recipe.
4# Patches could not be applied cleanly when systemd in OE is updated,
5# though we don't expect a lot of changes could happen in bootloader.
6# RMC is designed to support a large number of types of boards, so we
7# should do explicit update with validation to prevent regression even
8# resolving conflicts for a new tip could be done in a short time.
9
10# Revision: systemd v232 in OE
11SRCREV_intel-x86-common = "a1e2ef7ec912902d8142e7cb5830cbfb47dba86c"
12
13include systemd-boot/${EFI_PROVIDER}.inc 3include systemd-boot/${EFI_PROVIDER}.inc
14 4
15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" 5PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"