summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch45
-rw-r--r--recipes-bsp/thermald/thermald_1.9.1.bb (renamed from recipes-bsp/thermald/thermald_1.9.bb)5
2 files changed, 2 insertions, 48 deletions
diff --git a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch b/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
deleted file mode 100644
index eaa0da61..00000000
--- a/recipes-bsp/thermald/thermald/0001-Use-correct-format-specifier-for-size_t.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From dcdaf523393a6e7c07b5a510c573223722b0289b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 1 Aug 2019 08:15:52 +0800
4Subject: [PATCH] Use correct format specifier for size_t
5
6%zu instead of %lu, otherwise on 32 bit:
7
8| In file included from ../git/src/thd_common.h:27,
9| from ../git/src/thd_zone.h:30,
10| from ../git/src/thd_zone.cpp:34:
11| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::update_highest_trip_temp(cthd_trip_point&)':
12| ../git/src/thd_zone.cpp:322:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
13| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
14| | ^~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~
15| | |
16| | std::vector<cthd_trip_point>::size_type {aka unsigned int}
17| ../git/src/thermald.h:82:57: note: in definition of macro 'thd_log_info'
18| 82 | #define thd_log_info(...) g_log(NULL, G_LOG_LEVEL_INFO, __VA_ARGS__)
19| | ^~~~~~~~~~~
20| ../git/src/thd_zone.cpp:322:38: note: format string is defined here
21| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
22| | ~~^
23| | |
24| | long unsigned int
25| | %u
26
27Upstream-Status: Submitted [https://github.com/intel/thermal_daemon/pull/198]
28Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
29---
30 src/thd_zone.cpp | 2 +-
31 1 file changed, 1 insertion(+), 1 deletion(-)
32
33diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
34index dd485d9..eb81d61 100644
35--- a/src/thd_zone.cpp
36+++ b/src/thd_zone.cpp
37@@ -319,7 +319,7 @@ void cthd_zone::add_trip(cthd_trip_point &trip) {
38 void cthd_zone::update_highest_trip_temp(cthd_trip_point &trip)
39 {
40 if (trip_points.size()) {
41- thd_log_info("trip_points.size():%lu\n", trip_points.size());
42+ thd_log_info("trip_points.size():%zu\n", trip_points.size());
43 for (unsigned int j = trip_points.size() - 1;; --j) {
44 if (trip_points[j].get_trip_type() == trip.get_trip_type()) {
45 thd_log_info("updating existing trip temp \n");
diff --git a/recipes-bsp/thermald/thermald_1.9.bb b/recipes-bsp/thermald/thermald_1.9.1.bb
index 718e0d4c..e38e3f52 100644
--- a/recipes-bsp/thermald/thermald_1.9.bb
+++ b/recipes-bsp/thermald/thermald_1.9.1.bb
@@ -13,10 +13,9 @@ DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2" 13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848" 14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15 15
16SRC_URI = "git://github.com/intel/thermal_daemon \ 16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Use-correct-format-specifier-for-size_t.patch \
18 " 17 "
19SRCREV = "7f573b681a25b5ffbe81103ba9fdcf7fec0f2884" 18SRCREV = "7e23f7cc4611fd7289014c9805749ec75d59bae0"
20S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
21 20
22inherit pkgconfig autotools systemd 21inherit pkgconfig autotools systemd