summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf5
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb31
2 files changed, 33 insertions, 3 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index e5bd2189..ac7c8f97 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -23,11 +23,10 @@ LAYERSERIES_COMPAT_intel = "thud warrior"
23BBFILES_DYNAMIC += " \ 23BBFILES_DYNAMIC += " \
24 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bb \ 24 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bb \
25 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bbappend \ 25 clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bbappend \
26"
27
28BBFILES_DYNAMIC += " \
29 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \ 26 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \
30 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \ 27 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
28 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bb \
29 meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bbappend \
31" 30"
32 31
33require ${LAYERDIR}/conf/include/maintainers.inc 32require ${LAYERDIR}/conf/include/maintainers.inc
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb
new file mode 100644
index 00000000..0a622ca6
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
9 "
10SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 mkdir -p ${D}${datadir}/openvino/model-optimizer
19 cp -r model-optimizer ${D}${datadir}/openvino/
20}
21
22RDEPENDS_${PN} += " \
23 python3-numpy \
24 python3-protobuf \
25 python3-defusedxml \
26 python3-networkx \
27 python3-test-generator \
28 bash \
29 "
30
31FILES_${PN} += "${datadir}/openvino"