summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/igt-gpu-tools/files/0001-lib-fb-Fix-rgb24-to-nv12-conversion.patch40
-rw-r--r--recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.24.bb (renamed from recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb)19
2 files changed, 7 insertions, 52 deletions
diff --git a/recipes-graphics/igt-gpu-tools/files/0001-lib-fb-Fix-rgb24-to-nv12-conversion.patch b/recipes-graphics/igt-gpu-tools/files/0001-lib-fb-Fix-rgb24-to-nv12-conversion.patch
deleted file mode 100644
index 46b2eef5..00000000
--- a/recipes-graphics/igt-gpu-tools/files/0001-lib-fb-Fix-rgb24-to-nv12-conversion.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From f01796214bbde31e37b0593e547ad9436fdd02ba Mon Sep 17 00:00:00 2001
2From: Petri Latvala <petri.latvala@intel.com>
3Date: Wed, 9 Jan 2019 14:28:29 +0200
4Subject: [PATCH] lib/fb: Fix rgb24 to nv12 conversion
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9A typo fix in 1x2 pixel block conversion code, revealed by GCC 9
10
11Fixes: 1c7ef3890045 ("lib: Use igt_matrix for ycbcr<->rgb conversion")
12Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109257
13Reported-by: Martin Liska <mliska@suse.cz>
14Signed-off-by: Petri Latvala <petri.latvala@intel.com>
15Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
16Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
17Reviewed-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
18
19Upstream-Status: Backport
20Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
21---
22 lib/igt_fb.c | 2 +-
23 1 file changed, 1 insertion(+), 1 deletion(-)
24
25diff --git a/lib/igt_fb.c b/lib/igt_fb.c
26index 8244e517..5cd1829a 100644
27--- a/lib/igt_fb.c
28+++ b/lib/igt_fb.c
29@@ -1779,7 +1779,7 @@ static void convert_rgb24_to_nv12(struct fb_convert *cvt)
30 struct igt_vec4 yuv[2];
31
32 read_rgb(&rgb[0], &rgb24[j * 8 + 0]);
33- read_rgb(&rgb[2], &rgb24[j * 8 + 0 + rgb24_stride]);
34+ read_rgb(&rgb[1], &rgb24[j * 8 + 0 + rgb24_stride]);
35
36 yuv[0] = igt_matrix_transform(&m, &rgb[0]);
37 yuv[1] = igt_matrix_transform(&m, &rgb[1]);
38--
392.20.1
40
diff --git a/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb b/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.24.bb
index 33c04e77..156798c6 100644
--- a/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.23.bb
+++ b/recipes-graphics/igt-gpu-tools/igt-gpu-tools_1.24.bb
@@ -3,32 +3,27 @@ require ${COREBASE}/meta/recipes-graphics/xorg-app/xorg-app-common.inc
3SUMMARY = "Intel GPU tools" 3SUMMARY = "Intel GPU tools"
4DESCRIPTION = "Variety of small tools for testing intel graphics." 4DESCRIPTION = "Variety of small tools for testing intel graphics."
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4b3dd344780e0400593b21b115a6947" 6LIC_FILES_CHKSUM = "file://COPYING;md5=67bfee4df38fa6ecbe3a675c552d4c08"
7 7
8LICENSE_append = " & ISC" 8LICENSE_append = " & ISC"
9 9
10inherit autotools gtk-doc 10inherit autotools
11 11
12SRC_URI = "${XORG_MIRROR}/individual/app/${BP}.tar.xz \ 12SRC_URI = "${XORG_MIRROR}/individual/app/${BP}.tar.xz"
13 file://0001-lib-fb-Fix-rgb24-to-nv12-conversion.patch \
14 "
15 13
16DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr procps libunwind kmod openssl" 14DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr procps libunwind kmod openssl elfutils"
17RDEPENDS_${PN} += "bash" 15RDEPENDS_${PN} += "bash"
18RDEPENDS_${PN}-tests += "bash" 16RDEPENDS_${PN}-tests += "bash"
19 17
20PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests" 18PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests"
21 19
22SRC_URI[md5sum] = "04c1f10d6fd85e079271540b0ea786e9" 20SRC_URI[md5sum] = "0e0b4a1a80dc2e09c2705e0c5159e0a1"
23SRC_URI[sha256sum] = "4d4b086c513bace5c23d0889de3f42ac3ebd3d968c64dedae6e28e006a499ad0" 21SRC_URI[sha256sum] = "57357c72feeafc923c9cfd2d1234bd80e120fc7cc6099eac81158ec351a821bf"
24 22
25EXTRA_OECONF = "--disable-nouveau --disable-shader-debugger" 23EXTRA_OECONF = "--disable-nouveau"
26COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" 24COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
27COMPATIBLE_HOST_libc-musl_class-target = "null" 25COMPATIBLE_HOST_libc-musl_class-target = "null"
28 26
29PACKAGECONFIG ??= ""
30PACKAGECONFIG[audio] = "--enable-audio,--disable-audio,alsa-lib gsl"
31
32gputools_sysroot_preprocess() { 27gputools_sysroot_preprocess() {
33 rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc 28 rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc
34} 29}