summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/libva/intel-vaapi-driver/0001-Fix-HEVCe-kernel-compile-error-on-gcc10.patch35
-rw-r--r--recipes-multimedia/libva/intel-vaapi-driver/0002-test-cast-VA_STATSUS_ERROR_UNKNOWN-to-VAStatus.patch33
-rw-r--r--recipes-multimedia/libva/intel-vaapi-driver_2.4.1.bb (renamed from recipes-multimedia/libva/intel-vaapi-driver_2.4.0.bb)5
3 files changed, 1 insertions, 72 deletions
diff --git a/recipes-multimedia/libva/intel-vaapi-driver/0001-Fix-HEVCe-kernel-compile-error-on-gcc10.patch b/recipes-multimedia/libva/intel-vaapi-driver/0001-Fix-HEVCe-kernel-compile-error-on-gcc10.patch
deleted file mode 100644
index f7af3c4f..00000000
--- a/recipes-multimedia/libva/intel-vaapi-driver/0001-Fix-HEVCe-kernel-compile-error-on-gcc10.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From b39e160d3974613328c570f46ecbcbcb70a5101b Mon Sep 17 00:00:00 2001
2From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
3Date: Tue, 12 May 2020 11:01:30 -0700
4Subject: [PATCH 1/2] Fix HEVCe kernel compile error on gcc10
5
6This fixes a "multiple definition" compiler error on
7gcc10 which defaults to -fno-common.
8
9https://gcc.gnu.org/gcc-10/porting_to.html#common
10
11Fixes #503
12
13Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
14
15Upstream-Status: Backport [https://github.com/intel/intel-vaapi-driver/commit/b39e160d3974613328c570f46ecbcbcb70a5101b]
16Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
17---
18 src/gen9_hevc_enc_kernels_binary.h | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/src/gen9_hevc_enc_kernels_binary.h b/src/gen9_hevc_enc_kernels_binary.h
22index 29659fa..ff7d0af 100644
23--- a/src/gen9_hevc_enc_kernels_binary.h
24+++ b/src/gen9_hevc_enc_kernels_binary.h
25@@ -31,6 +31,6 @@
26
27 #define GEN9_HEVC_ENC_KERNEL_SIZE 149296
28
29-const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
30+extern const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
31
32 #endif
33--
342.25.4
35
diff --git a/recipes-multimedia/libva/intel-vaapi-driver/0002-test-cast-VA_STATSUS_ERROR_UNKNOWN-to-VAStatus.patch b/recipes-multimedia/libva/intel-vaapi-driver/0002-test-cast-VA_STATSUS_ERROR_UNKNOWN-to-VAStatus.patch
deleted file mode 100644
index d17d901c..00000000
--- a/recipes-multimedia/libva/intel-vaapi-driver/0002-test-cast-VA_STATSUS_ERROR_UNKNOWN-to-VAStatus.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 625d2651258db881d92eb5ffc97cb4f4f1fda239 Mon Sep 17 00:00:00 2001
2From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
3Date: Tue, 12 May 2020 11:03:26 -0700
4Subject: [PATCH 2/2] test: cast VA_STATSUS_ERROR_UNKNOWN to VAStatus
5
6This fixes a gcc10 compiler error for the
7VA_STATUS_ERROR_UNKNOWN 0xFFFFFFFF conversion from
8unsigned int to int.
9
10Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
11
12Upstream-Status: Backport [https://github.com/intel/intel-vaapi-driver/commit/625d2651258db881d92eb5ffc97cb4f4f1fda239]
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 test/test.h | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/test/test.h b/test/test.h
19index 5d3fdc8..fc23ad1 100644
20--- a/test/test.h
21+++ b/test/test.h
22@@ -147,7 +147,7 @@ public:
23 status = "VA_STATUS_ERROR_HW_BUSY"; break;
24 case VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE:
25 status = "VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE"; break;
26- case VA_STATUS_ERROR_UNKNOWN:
27+ case VAStatus(VA_STATUS_ERROR_UNKNOWN):
28 status = "VA_STATUS_ERROR_UNKNOWN"; break;
29 default:
30 status = "Unknown VAStatus";
31--
322.25.4
33
diff --git a/recipes-multimedia/libva/intel-vaapi-driver_2.4.0.bb b/recipes-multimedia/libva/intel-vaapi-driver_2.4.1.bb
index 48e53f95..2112af2c 100644
--- a/recipes-multimedia/libva/intel-vaapi-driver_2.4.0.bb
+++ b/recipes-multimedia/libva/intel-vaapi-driver_2.4.1.bb
@@ -14,12 +14,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
14DEPENDS = "libva libdrm" 14DEPENDS = "libva libdrm"
15 15
16SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.bz2 \ 16SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.bz2 \
17 file://0001-Fix-HEVCe-kernel-compile-error-on-gcc10.patch \
18 file://0002-test-cast-VA_STATSUS_ERROR_UNKNOWN-to-VAStatus.patch \
19 " 17 "
20 18
21SRC_URI[md5sum] = "731dd9aaf9f5ef1b9c906ce82ef0220b" 19SRC_URI[sha256sum] = "0081fce08eb3a83f7d99c3b853c8fdfa0af437b8f5b0fb7c66faeb83bcbe0c19"
22SRC_URI[sha256sum] = "71e2ddd985af6b221389db1018c4e8ca27a7f939fb51dcdf49d0efcb5ff3d089"
23 20
24UPSTREAM_CHECK_URI = "https://github.com/intel/intel-vaapi-driver/releases" 21UPSTREAM_CHECK_URI = "https://github.com/intel/intel-vaapi-driver/releases"
25 22