summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc4
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch31
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb2
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb3
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb16
5 files changed, 54 insertions, 2 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index 1bd2a26e..da481fce 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -4,12 +4,13 @@ LICENSE = "BSD & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe"
5 5
6SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \ 6SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ 7 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \ 8 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
10 file://dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch \ 9 file://dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch \
11 " 10 "
12 11
12COMPATIBLE_MACHINE = "crystalforest|intel-corei7-64"
13
13# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat. 14# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
14# fuse is in meta-filesystems and qat is not yet upstreamed. 15# fuse is in meta-filesystems and qat is not yet upstreamed.
15# So adding mechanism to explicitly disable the use of fuse and qat. 16# So adding mechanism to explicitly disable the use of fuse and qat.
@@ -54,6 +55,7 @@ def get_dpdk_target_mach(bb, d):
54 "crystalforest": "ivb", 55 "crystalforest": "ivb",
55 "romley": "snd", 56 "romley": "snd",
56 "romley-ivb": "ivb", 57 "romley-ivb": "ivb",
58 "intel_corei7_64": "hsw",
57 } 59 }
58 60
59 if target_arch in multiarch_options : 61 if target_arch in multiarch_options :
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
new file mode 100644
index 00000000..cd517052
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
@@ -0,0 +1,31 @@
1From a424a79b1422f1877de3ee7aee6f781aeacc3630 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Tue, 18 Aug 2015 12:36:02 +0800
4Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat
5
6Upstream-Status: Inappropriate [configuration]
7
8Add CONFIG_EXAMPLE_DPDK_QAT to control compilation of dpdk_qat
9example by PACKAGECONFIG
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index b4eddbd..1bc14b0 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -41,7 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
21 DIRS-y += cmdline
22 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
23 ifneq ($(ICP_ROOT),)
24-DIRS-y += dpdk_qat
25+DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
26 endif
27 DIRS-y += exception_path
28 DIRS-y += helloworld
29--
301.7.9.5
31
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
index b1a3aea5..a6b2aed6 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
@@ -1,5 +1,7 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI += "file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch"
4
3SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22" 5SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22"
4SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939" 6SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939"
5 7
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
index cb1b1d3f..33ebaac4 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
@@ -1,7 +1,8 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI += "file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \ 3SRC_URI += "file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \
4 " 4 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
5 "
5 6
6SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934" 7SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934"
7SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f" 8SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f"
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
new file mode 100644
index 00000000..7a7af6fe
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
@@ -0,0 +1,16 @@
1include dpdk.inc
2
3SRC_URI += "\
4 file://dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch \
5 file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \
6 "
7
8SRC_URI[dpdk.md5sum] = "205a0d12bfd6eb717d57506272f43519"
9SRC_URI[dpdk.sha256sum] = "f7b322867a45f99afd9c8fbacdc56e1621676f9ca0f046656ec85eb6a99a3440"
10
11export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
12export ARCHDIR = "generic"
13
14do_configure_prepend () {
15 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
16}