summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-crystalforest/README25
-rw-r--r--meta-crystalforest/recipes-extended/qat/qat16_2.3.0-34.bb2
-rw-r--r--meta-crystalforest/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb2
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc31
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch48
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch50
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch31
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb22
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb23
11 files changed, 135 insertions, 185 deletions
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
index 2053a3c2..f549f907 100644
--- a/meta-crystalforest/README
+++ b/meta-crystalforest/README
@@ -204,12 +204,37 @@ Note:
204qat16 recipe is meant for platform with Coleto Creek chipset. 204qat16 recipe is meant for platform with Coleto Creek chipset.
205qat15 recipe is meant for platform with Cave Creek chipset. 205qat15 recipe is meant for platform with Cave Creek chipset.
206 206
207conf/machine/crystalforest.conf is the common machine configuration
208to support Crystal Forest/server, Crystal Forest/gladden, Highland Forest and
209River Forest. In order to generate the right binary for these platforms which
210have different QAT technology, user could change the default config accordingly
211within crystalforest.conf as below:
212
213For Coleto Creek chipset:
214PREFERRED_PROVIDER_virtual/qat ?= "qat16"
215
216For Cave Creek chipset:
217PREFERRED_PROVIDER_virtual/qat ?= "qat15"
218
219Another option and preferred approach for above setting is to override
220configuration under build/conf/local.conf as follow:
221
222For Coleto Creek chipset:
223PREFERRED_PROVIDER_virtual/qat = "qat16"
224
225For Cave Creek chipset:
226PREFERRED_PROVIDER_virtual/qat = "qat15"
227
207By default, the machine configuration does not assume that the above 228By default, the machine configuration does not assume that the above
208ingredients are pre-installed onto the BSP. Developers are required 229ingredients are pre-installed onto the BSP. Developers are required
209to either use smart tool to install those software packages or 230to either use smart tool to install those software packages or
210configure IMAGE_INSTALL under build/conf/local.conf, for example. 231configure IMAGE_INSTALL under build/conf/local.conf, for example.
211 232
233For Coleto Creek chipset:
212IMAGE_INSTALL += "dpdk qat16 zlib-qat" 234IMAGE_INSTALL += "dpdk qat16 zlib-qat"
213 235
236For Cavecreek Creek chipset:
237IMAGE_INSTALL += "dpdk qat15 zlib-qat"
238
214The list of packages can be searched under tmp/deploy/<package-type> 239The list of packages can be searched under tmp/deploy/<package-type>
215folder. 240folder.
diff --git a/meta-crystalforest/recipes-extended/qat/qat16_2.3.0-34.bb b/meta-crystalforest/recipes-extended/qat/qat16_2.3.0-34.bb
index e6556cbe..83ccbfb1 100644
--- a/meta-crystalforest/recipes-extended/qat/qat16_2.3.0-34.bb
+++ b/meta-crystalforest/recipes-extended/qat/qat16_2.3.0-34.bb
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "\
9 " 9 "
10PV = "2.3.0-34" 10PV = "2.3.0-34"
11DEPENDS += "zlib openssl" 11DEPENDS += "zlib openssl"
12PROVIDES += "virtual/qat"
13
12SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \ 14SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \
13 file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \ 15 file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \
14 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \ 16 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \
diff --git a/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb
index e2d2c451..eb209b1b 100644
--- a/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb
+++ b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/zlib-${ZLIB_VERSION}/zlib.h;beginline=4;en
14 14
15# For target side versions of openssl enable support for OCF Linux driver 15# For target side versions of openssl enable support for OCF Linux driver
16# if they are available. 16# if they are available.
17DEPENDS += "cryptodev-linux pkgconfig qat16" 17DEPENDS += "cryptodev-linux pkgconfig virtual/qat"
18 18
19SRC_URI = "http://www.zlib.net/zlib-${ZLIB_VERSION}.tar.gz;name=zlib \ 19SRC_URI = "http://www.zlib.net/zlib-${ZLIB_VERSION}.tar.gz;name=zlib \
20 https://01.org/sites/default/files/page/zlib_shim_0.4.7-002_withdocumentation.zip;name=zlibqat \ 20 https://01.org/sites/default/files/page/zlib_shim_0.4.7-002_withdocumentation.zip;name=zlibqat \
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index 85b88fa0..1bd2a26e 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -3,6 +3,27 @@ HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD & LGPLv2 & GPLv2" 3LICENSE = "BSD & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe"
5 5
6SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
10 file://dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch \
11 "
12
13# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
14# fuse is in meta-filesystems and qat is not yet upstreamed.
15# So adding mechanism to explicitly disable the use of fuse and qat.
16# To enable, uncomment the below line or include in .bbappend.
17# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
18
19PACKAGECONFIG[dpdk_qat] = ",,virtual/qat"
20PACKAGECONFIG[vhost] = ",,fuse"
21PACKAGECONFIG[libvirt] = ",,libvirt"
22
23export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
24export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
25export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
26
6RDEPENDS_${PN} += "python-subprocess" 27RDEPENDS_${PN} += "python-subprocess"
7DEPENDS = "virtual/kernel" 28DEPENDS = "virtual/kernel"
8do_configure[depends] += "virtual/kernel:do_shared_workdir" 29do_configure[depends] += "virtual/kernel:do_shared_workdir"
@@ -20,6 +41,7 @@ export RTE_KERNELDIR_OUT = "${STAGING_KERNEL_BUILDDIR}"
20export INSTALL_PATH = "${prefix}/dpdk" 41export INSTALL_PATH = "${prefix}/dpdk"
21export SYSROOTPATH = "--sysroot=${STAGING_DIR_HOST}" 42export SYSROOTPATH = "--sysroot=${STAGING_DIR_HOST}"
22export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}" 43export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}"
44export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac"
23 45
24# The list of intel Comms platforms and their target machine 46# The list of intel Comms platforms and their target machine
25# process mapping. The supported target machine is listed under 47# process mapping. The supported target machine is listed under
@@ -46,6 +68,15 @@ do_configure () {
46 ############################################################# 68 #############################################################
47 unset prefix 69 unset prefix
48 70
71 # Fix-up CONFIG_RTE_MACHINE based on target machine
72 sed -e "s#CONFIG_RTE_MACHINE=\"native\"#CONFIG_RTE_MACHINE=\"${DPDK_TARGET_MACH}\"#" -i ${S}/config/defconfig_x86_64-native-linuxapp-gcc
73 sed -e "s#CONFIG_RTE_MACHINE=\"native\"#CONFIG_RTE_MACHINE=\"${DPDK_TARGET_MACH}\"#" -i ${S}/config/defconfig_i686-native-linuxapp-gcc
74
75 # Fix-up vhost configs based on package config
76 sed -e "s#CONFIG_RTE_KNI_VHOST=n#CONFIG_RTE_KNI_VHOST=${CONFIG_VHOST_ENABLED}#" -i ${S}/config/common_linuxapp
77 sed -e "s#CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n#CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=${CONFIG_VHOST_ENABLED}#" -i ${S}/config/common_linuxapp
78 sed -e "s#CONFIG_RTE_LIBRTE_VHOST=n#CONFIG_RTE_LIBRTE_VHOST=${CONFIG_VHOST_ENABLED}#" -i ${S}/config/common_linuxapp
79
49 make O=$RTE_TARGET T=$RTE_TARGET config 80 make O=$RTE_TARGET T=$RTE_TARGET config
50} 81}
51 82
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
deleted file mode 100644
index 979541e9..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 6eaf6b1a61321acb824f9672c12d0e30a2110f52 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Mon, 16 Mar 2015 11:10:43 +0800
4Subject: [PATCH] DPDK: defconfig: add selectable RTE_MACHINE option
5
6In order to make sure that DPDK build environment config can handle the
7package being built on different build machine for different target machine
8which will have different x86 architecture intrinsics than the build machine,
9we introduce DPDK_TARGET_MACH to be tunable from dpdk recipe. The machine
10type can be under mk/machine folder.
11
12Upstream-Status: Inappropriate [configuration]
13
14Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
15---
16 config/defconfig_i686-native-linuxapp-gcc | 2 +-
17 config/defconfig_x86_64-native-linuxapp-gcc | 2 +-
18 2 files changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/config/defconfig_i686-native-linuxapp-gcc b/config/defconfig_i686-native-linuxapp-gcc
21index a90de9b..c9a74a5 100644
22--- a/config/defconfig_i686-native-linuxapp-gcc
23+++ b/config/defconfig_i686-native-linuxapp-gcc
24@@ -32,7 +32,7 @@
25
26 #include "common_linuxapp"
27
28-CONFIG_RTE_MACHINE="native"
29+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
30
31 CONFIG_RTE_ARCH="i686"
32 CONFIG_RTE_ARCH_I686=y
33diff --git a/config/defconfig_x86_64-native-linuxapp-gcc b/config/defconfig_x86_64-native-linuxapp-gcc
34index 60baf5b..0e4802d 100644
35--- a/config/defconfig_x86_64-native-linuxapp-gcc
36+++ b/config/defconfig_x86_64-native-linuxapp-gcc
37@@ -32,7 +32,7 @@
38
39 #include "common_linuxapp"
40
41-CONFIG_RTE_MACHINE="native"
42+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
43
44 CONFIG_RTE_ARCH="x86_64"
45 CONFIG_RTE_ARCH_X86_64=y
46--
471.7.9.5
48
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
new file mode 100644
index 00000000..75bb517d
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
@@ -0,0 +1,43 @@
1From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Fri, 24 Jul 2015 23:57:17 +0800
4Subject: [PATCH] dpdk: point to the right include and lib path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the right location of qat
9lac headers and library.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/dpdk_qat/Makefile | 7 ++-----
14 1 file changed, 2 insertions(+), 5 deletions(-)
15
16diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile
17index f1e06a1..5b906f7 100644
18--- a/examples/dpdk_qat/Makefile
19+++ b/examples/dpdk_qat/Makefile
20@@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c
21
22 CFLAGS += -O3
23 CFLAGS += $(WERROR_FLAGS)
24-CFLAGS += -I$(ICP_ROOT)/quickassist/include \
25- -I$(ICP_ROOT)/quickassist/include/lac \
26- -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include
27+CFLAGS += -I$(ICP_LAC_API_DIR)
28
29 # From CRF 1.2 driver, library was renamed to libicp_qa_al.a
30 ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),)
31 ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a
32 else
33-ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a
34+ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a
35 endif
36
37-LDLIBS += -L$(ICP_ROOT)/build
38 LDLIBS += $(ICP_LIBRARY_PATH) \
39 -lz \
40 -losal \
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
deleted file mode 100644
index e8ded8d0..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From c1a59d62f2aa7656060d8ebcc8e45e852d931ff1 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Tue, 17 Feb 2015 00:23:12 +0800
4Subject: [PATCH] dpdk: enable VHOST build config in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
12---
13 config/common_linuxapp | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 2f9643b..67f5edb 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -361,9 +361,9 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 #
22 CONFIG_RTE_LIBRTE_KNI=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32@@ -372,7 +372,7 @@ CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
33 # fuse-devel is needed to run vhost.
34 # fuse-devel enables user space char driver development
35 #
36-CONFIG_RTE_LIBRTE_VHOST=n
37+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
38 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
39
40 #
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
deleted file mode 100644
index 45ce5e05..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From 3d3c03d947394696565b3bb7bed8c900de057a28 Mon Sep 17 00:00:00 2001
2From: WU CHIA CHUAN <chia.chuan.wu@intel.com>
3Date: Thu, 2 Jul 2015 15:59:18 +0800
4Subject: [PATCH] dpdk enable VHOST and ip_fragmentation in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com>
12---
13 config/common_linuxapp | 11 ++++++++---
14 1 file changed, 8 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 0b25f34..000f950 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -406,19 +406,24 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 CONFIG_RTE_LIBRTE_KNI=y
22 CONFIG_RTE_KNI_PREEMPT_DEFAULT=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32 #
33+# Compile ip_fragmentation
34+#
35+CONFIG_RTE_IP_FRAG=y
36+
37+#
38 # Compile vhost library
39 # fuse-devel is needed to run vhost-cuse.
40 # fuse-devel enables user space char driver development
41 # vhost-user is turned on by default.
42 #
43-CONFIG_RTE_LIBRTE_VHOST=n
44+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
45 CONFIG_RTE_LIBRTE_VHOST_USER=y
46 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
47
48--
491.7.9.5
50
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch
new file mode 100644
index 00000000..c4c683e8
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch
@@ -0,0 +1,31 @@
1From ebf07e9708c96aa1e655127175c39ad6ae3fc5ae Mon Sep 17 00:00:00 2001
2From: WU CHIA CHUAN <chia.chuan.wu@intel.com>
3Date: Tue, 28 Jul 2015 13:12:21 +0800
4Subject: [PATCH] dpdk enable ip_fragmentation in common_linuxapp config
5
6Upstream-Status: Inappropriate [Configuration]
7
8Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com>
9---
10 config/common_linuxapp | 5 +++++
11 1 file changed, 5 insertions(+)
12
13diff --git a/config/common_linuxapp b/config/common_linuxapp
14index 0b25f34..8cd97d7 100644
15--- a/config/common_linuxapp
16+++ b/config/common_linuxapp
17@@ -354,6 +354,11 @@ CONFIG_RTE_MAX_LCORE_FREQS=64
18 CONFIG_RTE_LIBRTE_NET=y
19
20 #
21+# Compile ip_fragmentation
22+#
23+CONFIG_RTE_IP_FRAG=y
24+
25+#
26 # Compile librte_ip_frag
27 #
28 CONFIG_RTE_LIBRTE_IP_FRAG=y
29--
301.9.1
31
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
index 5265a9cf..b1a3aea5 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
@@ -1,33 +1,11 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22" 3SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22"
12SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939" 4SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939"
13 5
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 6export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 7export ARCHDIR = "generic"
16 8
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
30
31do_install_append () { 9do_install_append () {
32 10
33 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp 11 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
index cb158b92..cb1b1d3f 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
@@ -1,29 +1,10 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \ 3SRC_URI += "file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \
4 file://dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch \ 4 "
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10 5
11SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934" 6SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934"
12SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f" 7SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f"
13 8
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 9export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 10export ARCHDIR = "generic"
16
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"