summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16.inc3
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch30
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16.inc b/meta-isg/common/recipes-extended/qat/qat16.inc
index e602dbd8..822db5d8 100644
--- a/meta-isg/common/recipes-extended/qat/qat16.inc
+++ b/meta-isg/common/recipes-extended/qat/qat16.inc
@@ -14,6 +14,7 @@ PROVIDES += "virtual/qat"
14SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \ 14SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \
15 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \ 15 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \
16 file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \ 16 file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \
17 file://qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch \
17 " 18 "
18 19
19COMPATIBLE_MACHINE = "crystalforest" 20COMPATIBLE_MACHINE = "crystalforest"
@@ -46,6 +47,8 @@ PARALLEL_MAKE = ""
46#To get around the double slashes in paths in QAT makefiles 47#To get around the double slashes in paths in QAT makefiles
47PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" 48PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
48 49
50EXTRA_OEMAKE_append = " CFLAGS+=-fgnu89-inline"
51
49do_unpack2() { 52do_unpack2() {
50 cd ${S}/ 53 cd ${S}/
51 tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz 54 tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
new file mode 100644
index 00000000..e1ed3fc9
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch
@@ -0,0 +1,30 @@
1From 83f465ee776868875f6c19c2110eed4db6c547ce Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Thu, 10 Sep 2015 11:58:44 +0800
4Subject: [PATCH] qat: make sure CFLAGS are correct
5
6Upstream-Status: Submitted
7
8Ensure that all the CFLAGS values are being considered.
9
10Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
11---
12 quickassist/adf/user/user_proxy/src/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/quickassist/adf/user/user_proxy/src/Makefile b/quickassist/adf/user/user_proxy/src/Makefile
16index 868313a..efd352c 100644
17--- a/quickassist/adf/user/user_proxy/src/Makefile
18+++ b/quickassist/adf/user/user_proxy/src/Makefile
19@@ -133,7 +133,7 @@ INCLUDES+= -I$(ADF_DIR)/include \
20 -I$(ADF_PLATFORM_DIR)/include \
21 -I$(ADF_CTL_DIR)/include
22
23-CFLAGS = -D_GNU_SOURCE -O2 $(INCLUDES)
24+CFLAGS += -D_GNU_SOURCE -O2 $(INCLUDES)
25 #needed by SAL
26 EXTRA_CFLAGS += -fPIC -fno-strict-aliasing
27 #include your $(ICP_OS)_$(ICP_OS_LEVEL).mk file
28--
291.7.9.5
30