diff options
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch | 31 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb | 4 |
2 files changed, 0 insertions, 35 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch deleted file mode 100644 index e9e9b439..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 88b961ce4e2c9744631c51d13fa638e8a8a6c2a9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lee Chee Yang <chee.yang.lee@intel.com> | ||
3 | Date: Wed, 2 Sep 2020 08:28:35 +0800 | ||
4 | Subject: [PATCH] Improve Reproducibility for src package | ||
5 | |||
6 | Improve reproducibility for intel-graphics-compiler-src package. | ||
7 | needs to pass build path as environment variable to the build. | ||
8 | |||
9 | Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream] | ||
10 | Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> | ||
11 | --- | ||
12 | visa/CMakeLists.txt | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt | ||
16 | index 9c169592..ecea91db 100644 | ||
17 | --- a/visa/CMakeLists.txt | ||
18 | +++ b/visa/CMakeLists.txt | ||
19 | @@ -105,8 +105,8 @@ endif() | ||
20 | # Set up the bison and flex targets. These commands will set up commands to generate the appropriate | ||
21 | # source files from the input grammars. It will also set up the dependencies correctly for any | ||
22 | # library or executable that uses the generated source | ||
23 | -BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-vt -p CISA") | ||
24 | -FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA ${WIN_FLEX_FLAG}") | ||
25 | +BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-vt -p CISA --file-prefix-map=$ENV{B}=/igc/") | ||
26 | +FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA -L ${WIN_FLEX_FLAG} ") | ||
27 | ADD_FLEX_BISON_DEPENDENCY(CISAScanner CISAParser) | ||
28 | |||
29 | add_custom_target(CISAScanner_target DEPENDS ${FLEX_CISAScanner_OUTPUTS} ${BISON_CISAParser_OUTPUTS}) | ||
30 | -- | ||
31 | 2.25.1 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb index 4625ba80..406f9f18 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4756.bb | |||
@@ -11,16 +11,12 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc | |||
11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ | 11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ |
12 | file://0001-skip-execution-of-ElfPackager.patch \ | 12 | file://0001-skip-execution-of-ElfPackager.patch \ |
13 | file://link-to-LLVMGenXIntrinsics.patch \ | 13 | file://link-to-LLVMGenXIntrinsics.patch \ |
14 | file://improve_src_package_reproducibility.patch \ | ||
15 | " | 14 | " |
16 | 15 | ||
17 | SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7" | 16 | SRCREV = "3623209b10b357ddb3a3d6eac3551c53ebc897f7" |
18 | 17 | ||
19 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
20 | 19 | ||
21 | # Used to replace with relative path in reproducibility patch | ||
22 | export B | ||
23 | |||
24 | inherit cmake | 20 | inherit cmake |
25 | 21 | ||
26 | COMPATIBLE_HOST = '(x86_64).*-linux' | 22 | COMPATIBLE_HOST = '(x86_64).*-linux' |