diff options
12 files changed, 219 insertions, 0 deletions
diff --git a/meta-chiefriver/COPYING.MIT b/meta-chiefriver/COPYING.MIT new file mode 100644 index 00000000..fb950dc6 --- /dev/null +++ b/meta-chiefriver/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-chiefriver/README b/meta-chiefriver/README new file mode 100644 index 00000000..49e44613 --- /dev/null +++ b/meta-chiefriver/README | |||
@@ -0,0 +1,107 @@ | |||
1 | This README file contains information on building the meta-chiefriver | ||
2 | BSP layer, and booting the images contained in the /binary directory. | ||
3 | Please see the corresponding sections below for details. | ||
4 | |||
5 | The 'Chief River' platform consists of the Intel Ivy Bridge processor, | ||
6 | plus the Panther Point PCH. This BSP assumes that the Ivy Bridge | ||
7 | integrated graphics are being used. | ||
8 | |||
9 | |||
10 | Dependencies | ||
11 | ============ | ||
12 | |||
13 | This layer depends on: | ||
14 | |||
15 | URI: git://git.openembedded.org/bitbake | ||
16 | branch: master | ||
17 | |||
18 | URI: git://git.openembedded.org/openembedded-core | ||
19 | layers: meta | ||
20 | branch: master | ||
21 | |||
22 | URI: git://git.yoctoproject.org/meta-intel | ||
23 | layers: intel | ||
24 | branch: master | ||
25 | |||
26 | |||
27 | Table of Contents | ||
28 | ================= | ||
29 | |||
30 | I. Building the meta-chiefriver BSP layer | ||
31 | II. Booting the images in /binary | ||
32 | |||
33 | |||
34 | I. Building the meta-chiefriver BSP layer | ||
35 | ========================================= | ||
36 | |||
37 | In order to build an image with BSP support for a given release, you | ||
38 | need to download the corresponding BSP tarball from the 'Board Support | ||
39 | Package (BSP) Downloads' page of the Yocto Project website. | ||
40 | |||
41 | Having done that, and assuming you extracted the BSP tarball contents | ||
42 | at the top-level of your yocto build tree, you can build a chiefriver | ||
43 | image by adding the location of the meta-chiefriver layer to | ||
44 | bblayers.conf, along with the meta-intel layer itself (to access | ||
45 | common metadata shared between BSPs) e.g.: | ||
46 | |||
47 | yocto/meta-intel \ | ||
48 | yocto/meta-intel/meta-chiefriver \ | ||
49 | |||
50 | To enable the chiefriver layer, add the chiefriver MACHINE to local.conf: | ||
51 | |||
52 | MACHINE ?= "chiefriver" | ||
53 | |||
54 | You should then be able to build a chiefriver image as such: | ||
55 | |||
56 | $ source oe-init-build-env | ||
57 | $ bitbake core-image-sato | ||
58 | |||
59 | At the end of a successful build, you should have a live image that | ||
60 | you can boot from a USB flash drive (see instructions on how to do | ||
61 | that below, in the section 'Booting the images from /binary'). | ||
62 | |||
63 | As an alternative to downloading the BSP tarball, you can also work | ||
64 | directly from the meta-intel git repository. For each BSP in the | ||
65 | 'meta-intel' repository, there are multiple branches, one | ||
66 | corresponding to each major release starting with 'laverne' (0.90), in | ||
67 | addition to the latest code which tracks the current master (note that | ||
68 | not all BSPs are present in every release). Instead of extracting a | ||
69 | BSP tarball at the top level of your yocto build tree, you can | ||
70 | equivalently check out the appropriate branch from the meta-intel | ||
71 | repository at the same location. | ||
72 | |||
73 | |||
74 | II. Booting the images in /binary | ||
75 | ================================= | ||
76 | |||
77 | This BSP contains bootable live images, which can be used to directly | ||
78 | boot Yocto off of a USB flash drive. | ||
79 | |||
80 | Under Linux, insert a USB flash drive. Assuming the USB flash drive | ||
81 | takes device /dev/sdf, use dd to copy the live image to it. For | ||
82 | example: | ||
83 | |||
84 | # dd if=core-image-sato-chiefriver-20101207053738.hddimg of=/dev/sdf | ||
85 | # sync | ||
86 | # eject /dev/sdf | ||
87 | |||
88 | This should give you a bootable USB flash device. Insert the device | ||
89 | into a bootable USB socket on the target, and power on. This should | ||
90 | result in a system booted to the Sato graphical desktop. | ||
91 | |||
92 | If you want a terminal, use the arrows at the top of the UI to move to | ||
93 | different pages of available applications, one of which is named | ||
94 | 'Terminal'. Clicking that should give you a root terminal. | ||
95 | |||
96 | If you want to ssh into the system, you can use the root terminal to | ||
97 | ifconfig the IP address and use that to ssh in. The root password is | ||
98 | empty, so to log in type 'root' for the user name and hit 'Enter' at | ||
99 | the Password prompt: and you should be in. | ||
100 | |||
101 | ---- | ||
102 | |||
103 | If you find you're getting corrupt images on the USB (it doesn't show | ||
104 | the syslinux boot: prompt, or the boot: prompt contains strange | ||
105 | characters), try doing this first: | ||
106 | |||
107 | # dd if=/dev/zero of=/dev/sdf bs=1M count=512 | ||
diff --git a/meta-chiefriver/README.sources b/meta-chiefriver/README.sources new file mode 100644 index 00000000..76180f1a --- /dev/null +++ b/meta-chiefriver/README.sources | |||
@@ -0,0 +1,17 @@ | |||
1 | The sources for the packages comprising the images shipped with this | ||
2 | BSP can be found at the following location: | ||
3 | |||
4 | http://downloads.yoctoproject.org/mirror/sources/ | ||
5 | |||
6 | The metadata used to generate the images shipped with this BSP, in | ||
7 | addition to the code contained in this BSP, can be found at the | ||
8 | following location: | ||
9 | |||
10 | http://www.yoctoproject.org/downloads/yocto-1.2/poky-denzil-7.0.tar.bz2 | ||
11 | |||
12 | The metadata used to generate the images shipped with this BSP, in | ||
13 | addition to the code contained in this BSP, can also be found at the | ||
14 | following locations: | ||
15 | |||
16 | git://git.yoctoproject.org/poky.git | ||
17 | git://git.yoctoproject.org/meta-intel | ||
diff --git a/meta-chiefriver/conf/layer.conf b/meta-chiefriver/conf/layer.conf new file mode 100644 index 00000000..5dc3c021 --- /dev/null +++ b/meta-chiefriver/conf/layer.conf | |||
@@ -0,0 +1,10 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "chiefriver" | ||
9 | BBFILE_PATTERN_chiefriver := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_chiefriver = "6" | ||
diff --git a/meta-chiefriver/conf/machine/chiefriver.conf b/meta-chiefriver/conf/machine/chiefriver.conf new file mode 100644 index 00000000..c9237f41 --- /dev/null +++ b/meta-chiefriver/conf/machine/chiefriver.conf | |||
@@ -0,0 +1,15 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: chiefriver | ||
3 | |||
4 | #@DESCRIPTION: Machine configuration for Chief River systems | ||
5 | # i.e. Ivy Bridge + Panther Point | ||
6 | |||
7 | PREFERRED_VERSION_linux-yocto ?= "3.2%" | ||
8 | |||
9 | require conf/machine/include/tune-x86_64.inc | ||
10 | require conf/machine/include/ia32-base.inc | ||
11 | |||
12 | XSERVER ?= "${XSERVER_IA32_BASE} \ | ||
13 | ${XSERVER_IA32_EXT} \ | ||
14 | ${XSERVER_IA32_I965} \ | ||
15 | " | ||
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig b/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig new file mode 100644 index 00000000..ffce0122 --- /dev/null +++ b/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig | |||
@@ -0,0 +1,3 @@ | |||
1 | # Assume a USB mouse and keyboard are connected | ||
2 | HAVE_TOUCHSCREEN=0 | ||
3 | HAVE_KEYBOARD=1 | ||
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend new file mode 100644 index 00000000..54da0ffd --- /dev/null +++ b/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC = "1" | ||
diff --git a/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend b/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend new file mode 100644 index 00000000..4631da3f --- /dev/null +++ b/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | RRECOMMENDS_task-core-tools-profile_append_chiefriver = " systemtap" | ||
2 | |||
diff --git a/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf new file mode 100644 index 00000000..96b94b46 --- /dev/null +++ b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf | |||
@@ -0,0 +1,26 @@ | |||
1 | Section "Device" | ||
2 | Identifier "Intel Graphics Driver" | ||
3 | Driver "intel" | ||
4 | EndSection | ||
5 | |||
6 | Section "Monitor" | ||
7 | Identifier "Generic Monitor" | ||
8 | Option "DPMS" | ||
9 | EndSection | ||
10 | |||
11 | Section "Screen" | ||
12 | Identifier "Default Screen" | ||
13 | Device "Intel Graphics Driver" | ||
14 | Monitor "Generic Monitor" | ||
15 | DefaultDepth 24 | ||
16 | EndSection | ||
17 | |||
18 | Section "ServerLayout" | ||
19 | Identifier "Default Layout" | ||
20 | Screen "Default Screen" | ||
21 | EndSection | ||
22 | |||
23 | Section "ServerFlags" | ||
24 | Option "DontZap" "0" | ||
25 | Option "AutoAddDevices" "False" | ||
26 | EndSection | ||
diff --git a/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend new file mode 100644 index 00000000..4b8d0e65 --- /dev/null +++ b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | ||
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend new file mode 100644 index 00000000..9e4a4a07 --- /dev/null +++ b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend | |||
@@ -0,0 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | COMPATIBLE_MACHINE_chiefriver = "chiefriver" | ||
3 | KMACHINE_chiefriver = "chiefriver" | ||
4 | |||
5 | # Update the following to use a different BSP branch or meta SRCREV | ||
6 | #KBRANCH_chiefriver = "standard/preempt-rt/base" | ||
7 | #SRCREV_machine_pn-linux-yocto-rt_chiefriver ?= XXXX | ||
8 | #SRCREV_meta_pn-linux-yocto-rt_chiefriver ?= XXXX | ||
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend new file mode 100644 index 00000000..0b707bed --- /dev/null +++ b/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend | |||
@@ -0,0 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | COMPATIBLE_MACHINE_chiefriver = "chiefriver" | ||
4 | KMACHINE_chiefriver = "chiefriver" | ||
5 | KBRANCH_chiefriver = "standard/default/common-pc-64/chiefriver" | ||
6 | |||
7 | SRCREV_machine_pn-linux-yocto_chiefriver ?= "dbe820c277dfa6cbc249d410e8b083286ec484b7" | ||
8 | SRCREV_meta_pn-linux-yocto_chiefriver ?= "353d43d340e87996b4be4c5f6ddb4447e050b65c" | ||